desktop crashes, vlc fails when I try to read a dvd movie

Asked by LEGOManiac on 2011-03-13

I'm trying to play a DVD movie under lubuntu. When I start it with VLC it plays briefly and fails. When I just try to open the Video_ts file, the desktop "crashes". That is to say, any open windows I have close, the desktop goes blank and a moment later resets itself to the plain desktop with menus - I presume it crashed and was automatically restarted.

I suspect the problem is with the codecs. I have the full medibuntu suite installed. Any other sources of codecs I can try?

For what it's worth, the k-lite codec suite in Windows won't play it either. I haven't had a chance yet to try it on a commercial DVD player.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-03-13
Last query:
2011-03-13
Last reply:
2011-03-13

Can you give the output of:

uname -a; lsb_release -a; echo; apt-cache policy vlc

Thanks

LEGOManiac (bzflaglegomaniac) said : #2

uname -a; lsb_release -a; echo; apt-cache policy vlc
Linux Dimension-2400 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:29 UTC 2011 i686 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

vlc:
  Installed: 1.1.4-1ubuntu1.4
  Candidate: 1.1.4-1ubuntu1.4
  Version table:
 *** 1.1.4-1ubuntu1.4 0
        500 http://ca.archive.ubuntu.com/ubuntu/ maverick-updates/universe i386 Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/universe i386 Packages
        100 /var/lib/dpkg/status
     1.1.4-1ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
r

LEGOManiac (bzflaglegomaniac) said : #3

It just occurred to me to try using a commercial DVD I've played before. The one I started this question with is a rental and as such, I can't be 100% sure it isn't defective.

Anyway, my original copy of Bourne:ultimatum does the same thing as described above.

Try:

sudo add-apt-repository ppa:n-muench/vlc; sudo apt-get update; sudo apt-get -y upgrade; sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update; sudo apt-get -y install libdvdread4; sudo /usr/share/doc/libdvdread4/install-css.sh; sudo apt-get -y upgrade

Will give vlc 1.1.7 and may help

LEGOManiac (bzflaglegomaniac) said : #5

Wow, that actually worked.
When File Manager kept crashing every time I opened a VIDEO_TS folder, I figured it was something wrong with File Manager. Given that I wasn't actually trying to play any media at that point, I wouldn't have guessed that trying to update VLC or the medibuntu codecs would have had anything to do with it. I figured you were barking up the wrong tree.

Thanks for the help. I would never have looked at medibuntu or vlc as the cause of File Manager crashing.

For my own future reference, so that I can better understand the steps involved, I'm separating out your script into different lines:

sudo add-apt-repository ppa:n-muench/vlc
sudo apt-get update
sudo apt-get -y upgrade
sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list
sudo apt-get --quiet update
sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring
sudo apt-get --quiet update
sudo apt-get -y install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get -y upgrade

LEGOManiac (bzflaglegomaniac) said : #6

Thanks actionparsnip, that solved my question.

You can run it as ONE lump. which is why I give it like that :)

glad you got the gold. Updating VLC and adding the medibuntu makes things work well. If you also run:

sudo apt-get install w32codecs mplayer-gnome

You can pretty much play anything.