alsa-lib 1.0.23 required

Asked by marcus aurelius on 2010-09-13

VLC aborts while playing and gives the following message.

Potential ALSA version problem:

VLC failed to initialize your sound output device (if any).

Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue.

Synaptic has only 1.0.22.

Where can the newer version be retrieved?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-13
Last reply:
2010-12-27

sudo add-apt-repository ppa:ricotz/unstable; sudo apt-get update; sudo apt-get upgrade

Should do it.

cecilia fx (ceciliafx) said : #2

is it safe to use an unstable alsa on Ubuntu 10.04?

cecilia fx (ceciliafx) said : #3

is it safe to use an unstable alsa on Ubuntu 10.04?

Yeah its fine.

Peter Martin (pe7ercom) said : #5

I had the same problem on Ubuntu 10.10 with VLC and Movie Player that both didn't play sound from .avi files.
With actionparsnip's command line upgrade of alsa-lib, the problem has been solved.

Thanks actionparsnip!

Can you help with this problem?

Provide an answer of your own, or ask marcus aurelius for more information if necessary.

To post a message you must log in.