Can't watch DVD's in 10.04

Asked by marbuntu on 2010-06-09

Hello everyone:

I am running 10.04 on a dell inspiron 1525 laptop and have tried various media players to watch DVD's but none seem to work. I tried movie player. It opens up and then closes. I tried VLC and it just sits there and doesn't open the DVD. I don't know of a way to watch DVD's. It shouldn't be this difficult. Can anyone assist me please? Thanks.

Mark

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
marbuntu
Solved:
2010-06-10
Last query:
2010-06-10
Last reply:
2010-06-10
marbuntu (markfpyles) said : #2

Hello and thank you for the information. I already had the Ubuntu-restricted-extras installed so I removed them and re-installed but it still didn't work. Movie player still crashes and VLC opens and tries to work and then crashes also. I'm not sure of what else to do. Thank you.

Mark

Open a terminal and run vlc from it simply type vlc and press enter then don't close the terminal and use vlc you will see errors when vlc close itself.

Please report some of them here.

Hth

marbuntu (markfpyles) said : #4

Hello:

I did what you said which I will paste below. Unfortunately when the interface appears it will not play any dvd's. when I try to play a DVD, I sometimes get could not read from resource. The DVD's are in mint condition and are not copied. They are the originals purchased from a retail store. They work in other DVD players what's hooked up to my tv so there shouldn't be anything wrong with the physical DVD's themselves. What else can I try? Thank you.

mark@mark-laptop:~$ vlc
VLC media player 1.0.6 Goldeneye
[0x864e668] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

marbuntu (markfpyles) said : #5

I just tried to play the DVD in Kaffeine and it looked like it started to play but then it gave me the error "Read error from" "Error reading NAV packet"

What does that mean? What is the NAV packet? Thank you.

Mark

Marbuntu,

DVD playback is NOT included in the *-restricted-extras packages! To install DVD support (assumes 9.10 or 10.04, for earlier versions add Medibuntu repository and install libdvdcss2):

    $ sudo apt-get install libdvdread4
    $ sudo /usr/share/doc/libdvdread4/install-css.sh (The IMPORTANT step!!!)

    NOTE: I have always had to reboot in order for this to take effect.

Good luck,
George

marbuntu (markfpyles) said : #7

Hi George:

That worked fantastic! Thank you very much!!!!!!!!!!!!

Mark