How to configure 5.1 channels output by default ?

Asked by Id2ndR on 2010-04-17

Each time I play a DVD on my setup, I have to switch to 5.1 channels (right clic > audio > audio device) instead of the default stereo to get 5.1 output.
I haven't found in the preferences where to set 5.1 channets output by default.

My simple question is : is it possible to configure the default channels output, and if it isn where is it ?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-23
Last reply:
2010-04-24
subliminalfix (subliminalfix) said : #1

what vesrion are you using ?

under your application>acessories>terminal copy in uname -a and should give you a pastable reply

hope that gets you going

Id2ndR (id2ndr) said : #2

vlc_1.0.5-2ubuntu3_amd64.deb on Ubuntu 10.04 (up to date).

Id2ndR (id2ndr) said : #4

I'm sorry but my question is related to VLC that doesn't automatically detect that my system have 5.1 output.

Maybe I should add some information:
- Totem, like SmPlayer have some options to use 5.1 channels instead of stereo.
- PA (pulseaudio) is configure to use 5.1 channels, so applications may be able to get the information that 5.1 output is possible.
- The method using .asoundrc file may work but it's not adapted to PA, and isn't the good way to configure the output with nowadays sound architecture (using ALSA directly is the past, and so .asoundrc file).
That's the reason why I can't consider this as a acceptable solution to my question.

Maybe my question doesn't have any smart solution today because VLC doesn't have a proper implementation of PA output filter ? Maybe the implementation is to currently too simple to handle a proper selection of the output ?

Id2ndR (id2ndr) said : #5

Just a comment to be able to click on a button (I should have done this before)

subliminalfix (subliminalfix) said : #6

have you enabled the pulse audio mixer from the add/remove. under applications or in sound preference with the second mouse gesture or possible from your system administrator synaptic

the usual is a generic sound device or the alsa mixer you would need to set the controls to use that gui

Id2ndR (id2ndr) said : #7

I haven't use the PA mixer in that computer.
However I correctly configure my sound card using gnome-volume-control to use my usb sound card (not a generic one) in 5.1 analogic mode (PA doesn't support 5.1 trough spdif yet).

I think that the trouble isn't related to PA features or configuration, but only to VLC interaction with it.
I can't imagine any new interaction between VPC and PA related to the installation of PA mixer or similar packages.

subliminalfix (subliminalfix) said : #8

sorry your having trouble , oddly enough it seems that there are some issues with the sound application in other areas as well

i have encountered issues with recording in the program audacity and had to go back to 9.04

the sound mapping has always had some "querks"

i would suggest changing this to a bug report

Can you help with this problem?

Provide an answer of your own, or ask Id2ndR for more information if necessary.

To post a message you must log in.