No sound on vanilla kubuntu + vlc

Asked by Shashank Chintalagiri on 2010-03-06

Binary package hint: vlc

vlc on a vanilla kubuntu lucid install produces no sound unless run with sudo and the vlc-wrapper.

problem is fixed when the user is added to the 'audio' group.

This probably needs to be fixed in the default groups unless vlc can be made to go through pulseaudio (if i understand the general sound configuration correctly).

version : 1.0.5-1ubuntu1

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Shashank Chintalagiri
Solved:
2010-04-12
Last query:
2010-04-12
Last reply:
2010-04-10

This question was originally filed as bug #533039.

Rémi Denis-Courmont (rdenis) said : #1

VLC needs the audio group if it's configured to use ALSA. This is not really an error.

Rémi Denis-Courmont (rdenis) said : #2

Make sure vlc-plugin-pulse is installed. If needed select PulseAudio explicitly as the audio output in the VLC preferences.

Don't have an appropriate installation to test it right now. However, vlc-plugin-pulse is installed (just checked) and hence has probably always been. That probably means the vlc package should be 'changed' to use pulseaudio instead of alsa, as this is a potentially annoying to problematic situation for the average user.

I'll try to test it on a fresh install of a recent release when I get some free time.