Firefox Sound fades

Asked by Drew on 2010-03-07

I just made the switch from Windows XP to Ubuntu 9.10. I'm fairly new to Linux as a whole, but so far everything has been good except my sound. It works on startup, and it works with miscellaneous programs like Pidgin, but when I try to watch something streaming from the web, the sound starts off strong and just fades to silence after a few seconds. It seems that this problem is only happening with firefox, I haven't had a chance to try anything in media player or rythmbox yet. I have flashplayer downloaded, and also the recommended video plugin when I did a search for drivers, but still not getting any sound from firefox. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-03-07
Last query:
2010-03-07
Last reply:
2010-03-07

Is this in flash?

Can you give the output of:

dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf; uname -a

If not please indicate what conent is having issues.

Thanks

Drew (drewsmith86) said : #2

This is in flash, but now that I have moved some of my mp3 files onto the computer it is happening to them as well, the sound starts off strong and fades to nothing after about 20 seconds.

I am not getting anything when I put the above information into the terminal, possibly I am typing it in wrong? I am getting video through flash, just not sound.

Can you give the output of:

sudo lshw -C sound

The command I give can be directly pasted into the terminal which is why I give the full and exact command

Can you give the output of the first command I gave too

Thanks

Drew (drewsmith86) said : #4

My apologies, this has been frustrating me all day and this whole format is overwhelming at first, not sure why I didn't think of copy and paste, might have something to do with the 13 hours I've spent today trying to make this transition go as smoothly as possible.

The output of your first command:
me -a
ii adobe-flashplugin 10.0.45.2-1karmic1 Adobe Flash Player plugin version 10
Linux drew 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:05:19 UTC 2010 i686 GNU/Linux

And the out put of this one:
 *-multimedia
       description: Audio device
       product: MCP51 High Definition Audio
       vendor: nVidia Corporation
       physical id: 10.1
       bus info: pci@0000:00:10.1
       version: a2
       width: 32 bits
       clock: 66MHz
       capabilities: pm msi ht bus_master cap_list
       configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2
       resources: irq:23 memory:fe024000-fe027fff

Thanks for your help, I ran out of options hours ago.

sudo apt-get --purge remove adobe-flashplugin; sudo apt-get --purge autoremove; sudo apt-get clean; sudo apt-get install flashplugin-nonfree

This will give the correct plugin for flash, you have a 32bit Ubuntu install which can make life easier.

Can you also give the output of:

lspci | grep -i sound; lspci | grep -i audio

See how sound goes in flash now.

Thanks

Drew (drewsmith86) said : #6

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

Ran the first command, but still no sound from flash, or mplayer.

Does it work ok in the liveCD environment. Boot to the CD you installed with and select "try ubuntu without making changes"

See if ts ok there.

Is the system a laptop?

Drew (drewsmith86) said : #8

It's a desktop, I booted from the CD and had the same problem there, and I ran a CD scan and it said there were no errors found.

I'd check the bug logs to see if there is similar activity reported. make sure you are fully updated with:

sudo apt-get update; sudo apt-get upgrade; sudo apt-get dist-upgrade

Sam_ (and-sam) said : #10

Maybe you could give it a try by turning off 'awesome' power saving.
gksudo gedit /etc/modprobe.d/alsa-base.conf

Find this line at the bottom of the file:
options snd-hda-intel power_save=10 power_save_controller=N

make it 0 (zero) instead:
options snd-hda-intel power_save=0 power_save_controller=N

Save the file, reboot and test.

Drew (drewsmith86) said : #11

I ran the update line and everything was up to date. I tried that change, to no avail, and now it seems I've lost my system sound as well. I'll keep searching, any other suggestions in the mean time are always appreciated.

Sam_ (and-sam) said : #12

btw. to get detailed output what might be wrong try working through this,
https://help.ubuntu.com/community/SoundTroubleshootingProcedure

the output of alsa report script may show some modprobe options which can be added to alsa-base.conf.
An example of such a file looks like this.
http://www.alsa-project.org/db/?f=b0c727baa412e9afa7673bfe5ec40eeeb8dcaeed

Drew (drewsmith86) said : #13

I started going through the trouble shooting steps listed, here is the output of one of the commands (it suggested I post it here) if that helps:
ALSA Information Script v 0.4.59
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See 'alsa-info.sh --help' for command line options.

Automatically upload ALSA information to pastebin? [y/N] : y
Uploading information to www.pastebin.ca ... Done!

Your ALSA information is located at http://pastebin.ca/1826920

Please inform the person helping you.

Also not sure if this helps to narrow the problem down at all, but I was having a similar issue with windows. My sound worked great on Windows and suddenly stopped working all together for flash player. The difference is that it still worked fine for media files.

Best Sam_ (and-sam) said : #15

Thanks for the info.
I can't see anything obvious missing, except some mixer controls are off or muted.
Maybe install gnome-alsamixer and unmute.
Well and of course the driver isn't the latest, but that's normal since it's from official repository.

Drew (drewsmith86) said : #16

Thanks Sam, that solved my question.