Virtual box broken after kernel update to 5.8

Asked by Pharma Eng on 2021-01-14

Hi, I got a problem in oracle Virtual box after update the kernel version from 5.4.0-XX to version 5.8.XXX on Focal Fossa. After system restart it can not load Windows virtual machine. Warning is: virtualbox-dkms doesn not have kernel module sources and has to be reinstalled. So after reinstall Virtual box is not working again. Tried some configuration without any success. Only good thing was that I have backup and after installing Ubuntu 18.04 virtual machine is now working again on a kernel 5.4.0-60. Does someone else got similar problem and where could be the problem? My hardware is i5-2430M CPU @ 2.40GHz × 4 , HD Graphics 3000, 8GB RAM, SSD 500. Something else: Kernel 5.8 delayed the system performance almost two times during the boot.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2021-01-14
Last query:
2021-01-14
Last reply:
2021-01-14

This question was reopened

Manfred Hampl (m-hampl) said : #1

Probably Bug #1901904 (solution already available in focal-proposed)

Which version of Virtualbox do you have installed and from which source (Ubuntu repositories or virtualbox.org)?

Virtual box v. 6.1.16 with same extension pack version.

Sorry, 6.1.16 r140961 (Qt5.9.5), installed from virtualbox.org as binary package.

Manfred Hampl (m-hampl) said : #5

What output do you receive for the command

vboxmanage --version

Output was 6.1.16r140961. But I already replaced Focal fossa 20.04 to Bionic beaver 18.04 and restored VB from backup. So I can not check anymore some other details.

Best Manfred Hampl (m-hampl) said : #7

What do you now expect from us? If you have found a solution, then you might close the question as "solved".

Thanks Manfred Hampl, that solved my question.