Update version of Virtualbox

Asked by Eduardo Gutierrez on 2020-11-15

Would like to update virtualbox to 6.1.16 and now is on 6.1.10. Probably next weeks it would be more releases ( 6.1.18 should be released the next week or so).
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Solved by:
Eduardo Gutierrez
Solved:
2020-11-18
Last query:
2020-11-18
Last reply:
2020-11-17

This question was reopened

Eduardo Gutierrez (eduardo74) said : #1

I meant to update focal ubuntu.

What is the output of:

lsb_release -a; uname -a; apt-cache policy virtualbox

Thanks

What is in the new version that you need so badly? It's only a minor version change....

Manfred Hampl (m-hampl) said : #4

Manfred Hampl suggests this article as an answer to your question:
FAQ #3037: “no rolling release”.

Manfred Hampl (m-hampl) said : #5

The virtualbox.org servers provide the newest version also in *.deb format.
https://www.virtualbox.org/wiki/Linux_Downloads
You can try installing that version.
Note: This is a foreign source, no warranty can be given.

Eduardo Gutierrez (eduardo74) said : #6

Thanks for your help.

My lsb_release -a; uname -a; apt-cache policy virtualbox

eduardo@MiPcLinux:~$ lsb_release -a; uname -a; apt-cache policy virtualbox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal
Linux MiPcLinux 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
virtualbox:
  Instalados: 6.1.10-dfsg-1~ubuntu1.20.04.1
  Candidato: 6.1.10-dfsg-1~ubuntu1.20.04.1
  Tabla de versión:
 *** 6.1.10-dfsg-1~ubuntu1.20.04.1 500
        500 http://mirror.nforce.com/pub/linux/ubuntu focal-updates/multiverse amd64 Packages
        100 /var/lib/dpkg/status
     6.1.6-dfsg-1 500
        500 http://mirror.nforce.com/pub/linux/ubuntu focal/multiverse amd64 Packages
eduardo@MiPcLinux:~$

The problem is that your version doenst depend on python2, if i want to install the binaries from virtualbox it has as dependencies pythonispython2. So i had to install python2 packages, which are deprecated.

Im a teacher of vocational education, an having the latest version is more secure and solves some problems. Suppose its not a great effort to release new version, one you have many versions released.

Thanks again

How is it more secure please? In what way?

Eduardo Gutierrez (eduardo74) said : #8

Tha main reason is the new features, also as said not depend on python2ispython... so to be more secure lets take a look about vulnerabilities of python2 packages.... Thanks for your help.