VirtualBox not working

Asked by Holonium on 2018-12-05

I am on Ubuntu 18.10 Cosmic and when I attempt to use VirtualBox, I end up having the system slow down, and VirtualBox will not launch at all. I have received several error messages, including
[code]Failed to reload daemon: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)[/code]
and a couple of others that I cannot find right now. If I come across them again, I will post them. My version of VirtualBox is 5.2.18-dfsg-2.
Edit:
Another error message is:
[code]WARNING: The character device /dev/vboxdrv does not exist.
  Please install the virtualbox-dkms package and the appropriate
  headers, most likely linux-headers-generic.

  You will not be able to start VMs until this problem is fixed.
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libQt5Core.so.5: cannot open shared object file: No such file or directory
[/code]

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Solved by:
Holonium
Solved:
2018-12-06
Last query:
2018-12-06
Last reply:
2018-12-06
Nong Quang Huong (nqhictu) said : #1

You can try:
sudo apt-get dist-upgrade

Manfred Hampl (m-hampl) said : #2

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
lscpu
dpkg -l | grep -i virtualb

Holonium (holonium2) said : #3

uname -a gives:
Linux DarkstarXII 4.18.0-12-generic #13-Ubuntu SMP Wed Nov 14 15:17:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid gives:
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

lscpu gives:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 2
Core(s) per socket: 2
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 58
Model name: Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz
Stepping: 9
CPU MHz: 1732.862
CPU max MHz: 3600.0000
CPU min MHz: 1200.0000
BogoMIPS: 5781.42
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 4096K
NUMA node0 CPU(s): 0-3 dpkg -l | grep -i virtualb
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts flush_l1d

dpkg -l | grep -i virtualb gives:
ii virtualbox 5.2.18-dfsg-2 amd64 x86 virtualization solution - base binaries
ii virtualbox-dkms 5.2.18-dfsg-2 all x86 virtualization solution - kernel module sources for dkms
ii virtualbox-qt 5.2.18-dfsg-2 amd64 x86 virtualization solution - Qt based user interface

Holonium (holonium2) said : #4

I did also try to perform sudo apt dist-upgrade, but that did not help.

Holonium (holonium2) said : #5

I ran the following command and it worked.
sudo apt-get remove libqt5core5a &&
sudo apt-get install libqt5core5a &&
sudo apt-get remove libdouble-conversion1 &&
sudo apt-get install libdouble-conversion1 &&
sudo apt-get install virtualbox-qt