Plans to upgrade the 'precise' version?

Asked by David Partain on 2014-07-28

Greetings,

The current 'precise' version (4.1.12) of the virtualbox packages does not work if you install the latest Hardware Enablement Stack (https://wiki.ubuntu.com/Kernel/LTSEnablementStack) kernel on Ubuntu 12.04. That installs a 3.13 kernel and the dkms bits no longer compile.

Is there any making the 4.3 packages available for precise?

Thanks.

David

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Last query:
2014-07-28
Last reply:
2014-07-28
David Partain (david-partain) said : #1

That, of course, should have read, "Are there any plans for making the 4.3 packages available for precise?" :-)

Manfred Hampl (m-hampl) said : #2

I suggest you report a bug, and hopefully the virtualbox version for Ubuntu will be adapted to work also with the Hardware Enablement Stack.

There is a 4.3 version for precise available in PPAs, e.g. https://launchpad.net/~ricotz/+archive/ubuntu/virtualization?field.series_filter=precise
Maybe this works for you.

The repos of LTS releases are rarely upgraded in favour of stability. If there is a significant reason to upgrade the version then the update will happen.

David Partain (david-partain) said : #4

Hi,

I have now filed a bug. (https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1349407) Without an upgrade of the packages, any Precise installations after 12.04.5 (Aug 7) will not be able to install virtualbox from the current universe packages. They simply don't compile with the 3.13 kernel.

Cheers,

David

Can you help with this problem?

Provide an answer of your own, or ask David Partain for more information if necessary.

To post a message you must log in.