I cannot enter commands at the command line in Ubuntu installed in Virtualbox as guest on Windows

Asked by Jim Pappas on 2012-11-30

I installed Ubuntu 12.10. I am using a Virtual Box on a Windows 7 OS. It worked for awhile. Yesterday there was a large file of updates that I downloaded. After the updates were installed I was instructed to restart the virtual machine. I did and everything worked fine. I did some work and powered off the virtual machine. Later I booted the system back up, logged in, and opened a command line window. The cursor had changed to a solid block from a hollow one, and now I cannot enter anything at the command line. The keyboard is ignored. The mouse works, and when I clicked on system status it shows all the USB devices, but doesn't mention the keyboard specifically. It does mention an "unknown device" which it says is captured. I presume that is the keyboard. Can you help? Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Pappas
Solved:
2012-11-30
Last query:
2012-11-30
Last reply:
2012-11-30

Have you tried xterm? Are you using a desktop OS or a server?

Jim Pappas (jediknight190501) said : #2

Windows 7, desktop. What is "xterm?"

Warren Hill (warren-hill) said : #3

Is it just in the terminal that the keyboard does not work or elsewhere too?

There are known issues running Ubuntu 12.10 inside virtualbox on windows 7. See here
http://askubuntu.com/questions/207813/why-does-an-ubuntu-12-10-guest-in-virtualbox-run-very-very-slowly

xterm is another terminal program

Jim Pappas (jediknight190501) said : #4

Hi Warren, Andrew,
I decided to just uninstall and reinstall Linux and the Virtual Box. That solved my problem. I didn't lose much work, so no worries. I'm good to go. Thanks for the help and thanks to launchpad for having this support feature.

Best Regards,
Jim Pappas

Steve Sauls (steve.sauls) said : #5

With Linux type OS's everything is a config file in your home directory. They are all hidden and begin with a period. Most problems like this are just a problem with a configuration file in your home directory. It takes a little digging but most of the time it is something as simple as a .file problem that makes it look like a huge problem. Just FYI