In 12.10 VBox has no access to Internet

Asked by ealthuis on 2012-10-19

Just upgraded to 12.10, now Virtual Box does not have access to the Internet.

Reinstalled VBox, and added Guest additions, but no program can get through to Internet.

VBox runs a copy of Windows XP and another copy of Windows 7

Both worked fine in 12.04 LTS

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Solved by:
ealthuis
Solved:
2012-10-20
Last query:
2012-10-20
Last reply:
2012-10-19
ealthuis (ealthuis) said : #1

I may add, that neither the laptop or any of the Windos OS's have been changed .

It thus appears to be a problem with the communications driver. This driver is faster connecting to WIFI as well as to Bluetooth, that is a positive improvement. The question is now how to connect VBox.

This laptop is used primarily to demonstrate Linux to interested parties, this problem does not look good.

Have you set the interface to bridged, so it gets an IP from the router?

ealthuis (ealthuis) said : #3

How, as far as I know nothing was changed?

Its worth exploring. Its a setting in virtualbox before you power on the system

ealthuis (ealthuis) said : #5

VBox settings is grayed out, any other ideas?

"before you power on the system"

The Vbox OS is powered on..isn't it...that's why

ealthuis (ealthuis) said : #7

No, when it was on and W XP loaded I could get to the settings, I found a drop down that read NAS, I changed it to bridged as you suggested and things worked. Thank you, I learmed something.

Now if you could only make 5 GHz work......

EA

Ilan Tal (ilan-tal) said : #8

Thanks for this question as I had exactly the same problem, with the same solution.
Ubuntu always amazes me anew in that so many good people are always ready and willing to help.

Ilan