VirtualBox 4.1_4.1.16 Host-only adapter has no name

Asked by LewG on 2012-06-13

New installlation of Ubuntu 12.04. (GUI changes are awful, bugs, no docs, ... but that isn't the problem here.)

I installed VirtualBox with a 32-bit RHEL guest.

I want to set up an adapter Host-only mode, however the Name field reads 'Not selected' and there is no way to change it.
Thus, the text window at the bottom of the settings page for VirtualBox reads "On the Network:Adapter 1 page, no host-only network adapter is selected'.

That name is normally vboxnet0, I find in various docs. Where is that defined, how to find it, what produces it?

This problem appears to be unique on the net, at least I can't find other people complaining about it.

-------------------

I can use NAT and bridging, no problem. I have installed guest additions. I just updated all of the packages in the guest.
I got through the USB setup issues, understand all that.

lsmod shows the 4 vbox drivers : vboxdrv, vboxnetflt, vboxnetadp, vboxpci

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu virtualbox Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-14
Last reply:
2012-09-10

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep virtualbox

Thanks

LewG (lew-glendenning) said : #2

lew@lew-cubic-x4:~/wsn$ lsb_release -a;uname -a; dpkg -l | grep virtualbox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux lew-cubic-x4 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii virtualbox-4.1 4.1.16-78094~Ubuntu~precise Oracle VM VirtualBox

----------------------

Installed the lsbs, then :
lew@lew-cubic-x4:~/wsn$ lsb_release -a;uname -a; dpkg -l | grep virtualbox
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux lew-cubic-x4 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii virtualbox-4.1 4.1.16-78094~Ubuntu~precise Oracle VM VirtualBox

--------------

But no change in VirtualBox settings for the networking. Do I need to restart VB, guest, host, ...?

Thank you for the attention to this.

If you make a new ubuntu user and log in as that and make a VM, is it ok?

LewG (lew-glendenning) said : #4

I ran virtualbox as root because restoring my working environment is a big pain.

No name for 'host-only' network interface appears.

What next?

menteetmaleo (smieciispam) said : #5

try run VirtualBox, then click file->preferences->network
there you can create host virtual adapter, name it and select IP. default name is 'vboxnet0' , thats why is is used among various docs.
cheers,
michal

Can you help with this problem?

Provide an answer of your own, or ask LewG for more information if necessary.

To post a message you must log in.