virtualbox not working after update to last kernel on gutsy

Asked by Mihai Chezan

On June, 20, 2008, my PC did an automatic update for the kernel. After this the ViirtualBox OSE doesn't work anymore with the message:

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Please install the virtualbox-ose-modules package for your kernel and execute '/etc/init.d/vboxdrv start' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

OS: Ubuntu Gutsy
Old kernel version: 2.6.22-14
New kernel version: 2.6.22-15
VirtualBox: virtualbox-ose 1.5.0-dfsg2-1ubuntu3 and virtualbox-ose-modules-2.6.22-14-generic

There is no virtualbox-ose-modules-2.6.22-15-generic to install.

Question information

English Edit question
Ubuntu virtualbox-ose Edit question
No assignee Edit question
Solved by:
Theodotos Andreou
Last query:
Last reply:
Revision history for this message
tehas (rl-stoner) said :

I have the same problem. I just applied a bunch of package updates with Synaptic and now Virtual Box won't run. I get the same error as described above.

uname -a shows me running 2.6.22-15-generic.

VirtualBox version is 'virtualbox-ose-modules-2.6.22-14-generic'.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please press ESC when you see the GRUB row and try to start using the 2.6.22-14-generic kernel
Then virtual-box work again.

Then try to find if there are some virtualbox-ose-modules-2.6.22-15-generic to install from repository: please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo aptitude search virtualbox-ose-modules

give your user password when requested, you don't see nothing when you type it, then press enter.

If there are please install them, type:
sudo install virtualbox-ose-modules-2.6.22-15-generic

Hope this helps

Revision history for this message
Mihai Chezan (mihai-chezan) said :

Thank you for the answer. Yes, selecting kernel 2.6.22-14 works.
The problem is there is no virtualbox-ose module for the new kernel, 2.6.22-15.
I chose to use the OSE version of virtualbox exactly for these kind of cases, thinking that it will be better integrated and kept up to date. So in my "naïveté" I assumed that when a new kernel is released the proper OSE modules will be compiled and made available to the public.

Revision history for this message
Best Theodotos Andreou (theodotos) said :

You can compile a new version of the vboxdrv module your selves. The procedure is:

sudo aptitude install module-assistant virtualbox-ose-source
sudo module-assistant prepare virtualbox-ose
sudo module-assistant auto-install virtualbox-ose

To test if the module is installed do:

ls -l /dev/vboxdrv


lsmod | grep vbox

If not installed do:

sudo modprobe vboxdrv

To automatically start on startup put it in end of the "/etc/modules" file:

echo vboxdrv >> /etc/modules

Revision history for this message
Mihai Chezan (mihai-chezan) said :

Thank you for the input.
The thing is that if I wanted to compile stuff myself I would have chosen Gentoo and not Ubuntu.
Anyway, I will close this now.

Revision history for this message
Mihai Chezan (mihai-chezan) said :

Thanks Theodotos Andreou, that solved my question.

Revision history for this message
tehas (rl-stoner) said :

I don't follow how this is solved? Are you expecting all Ubuntu users to compile the package or reboot their machine to catch the Grub option for downgrading to a prior kernel level?

I though Ubuntu was Linux for the general community?

Shouldn't it stay open until a 2.6.22-15 package is added to the repository?

Revision history for this message
Theodotos Andreou (theodotos) said :

Well virtualbox is a Universe package and supported by volunteers. So we appreciate any help they provide and if they delay to build some packages for newer kernels we still love them :)

Revision history for this message
Davor (davor-d29) said :

Hi everybody...

Got a new one here. I stupidly tried to install the VirtualBox 2.0.0 version from Innotek's home page (through Synaptic) on my Gutsy (kernel 2.6.22-15-generic). During the installation a window asked whether I wanted to delete old modules, so I answered Yes (the moron:). The install broke (and I didn't log the message) and VirtualBox wouldn't start. So I completely removed through Synaptic the 2.0.0 version and tried to reinstall the OSE version. The installation finishes fine, but when I try to start VirtualBox through a terminal it states: " Could not find VirtualBox installation. Please reinstall." Tried that and didn't help much. Then I dried the compile of modules described above by Theodotos (tnx by the way) and at least it showed the kernel module being loaded (which before didn't), but even after reinstalling VirtualBox I still get the message "Could not find VirtualBox installation. Please reinstall.". Checked on the fs and the directory VirtualBox is in /usr . Being desperate since I use the virtualization to run a specific program written for Windows and having my files stored on the virtual machine's "drive" I would really need to get this thing working again. Any help would be dearly appreciated (hell I'll even mail you a pack of beers :).
ehem and yes I'm still quite new to Linux so I don't know what outputs you might need, but will be happy to provide them if I'll know how.
Again thanks and keep up the great work and effort!