Virtual Box Issue afater upgrade to Natty Narwhal

Asked by Mark Johnston on 2011-06-12

I upgraded to natty from 10.04 going via 10.10
The 10.10 Upgrade went Ok with a warning re Virtual Box - but it still worked
I proceeded to do the natty upgrade.

However I had problems with Virtual Box ( I use it to run XP for Itunes)

Virtual Box started but the machine would not.

I googled the problem - Advice seemed to be uninstall and reinstall - did that but stall the machine does not start.

The Re-install was the 4.0.8 for Natty - the previous was 4.0.4

Error messages

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component: Machine
Interface: IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

Advice was to
sudo /etc/init.d/vboxdrv setup
[sudo] password for mark:
 * Stopping VirtualBox kernel modules [ OK ]
 * Uninstalling old VirtualBox DKMS kernel modules [ OK ]
 * Trying to register the VirtualBox kernel modules using DKMS
Error! Your kernel headers for kernel 2.6.38-10-generic-pae cannot be found at
/lib/modules/2.6.38-10-generic-pae/build or /lib/modules/2.6.38-10-generic-pae/source.

 * Failed, trying without DKMS
 * Recompiling VirtualBox kernel modules
 * Look at /var/log/vbox-install.log to find out what went wrong

/var/log/vbox-install.log is

Uninstalling modules from DKMS
  removing old DKMS module vboxhost version 4.0.8

------------------------------
Deleting module version: 4.0.8
completely from the DKMS tree.
------------------------------
Done.
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.0.8/source ->
                 /usr/src/vboxhost-4.0.8

DKMS: add Completed.
You can use the --kernelsourcedir option to tell DKMS where it's located, or you
 could install the linux-headers-2.6.38-10-generic-pae package.
Failed to install using DKMS, attempting to install without
Makefile:169: *** Error: unable to find the sources of your current Linux kernel
. Specify KERN_DIR=<directory> and run Make again. Stop.

Any advice welcome
Mark

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox-ose Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2011-06-14
Last query:
2011-06-14
Last reply:
2011-06-13
Wyatt Smith (wyatt-smith) said : #1

Looks like you are missing the kernel headers.

Sometimes these are held back during normal update. If they are held back, then

sudo apt-get dist-upgrade

will install them. If not, you may need to install the headers manually.

After the headers are install, you can then recomplie the vboxdrv for your current kernel.

Mark Johnston (mfsee) said : #2

Hi tried that and got this

sudo apt-get dist-upgrade
[sudo] password for mark:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ natty/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_natty_partner_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

Best delance (olivier-delance) said : #3

Go to System->Administration->Synaptic (packet manager) and install linux-headers-2.6.38-10-generic-pae package

Mark Johnston (mfsee) said : #4

Thanks delance, that solved my question.