mounting file system

Asked by Norbert Hoffmann on 2010-12-27

how to mount Windows file system of a host computer

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virtualbox-ose Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2010-12-29
Last query:
2010-12-29
Last reply:
2010-12-29
marcus aurelius (adbiz) said : #1

is this related to ubuntu?
if so, if you use gnome desktop, windoze drives are automatically mounted.

Norbert Hoffmann (norb1933) said : #2

Yes, it's ubuntu with gnome running inside an Oracle virtual machine. It doesn't mount the host file system

Andrew Hayzen (ahayzen) said : #3

Have you shared the filesystem as a shared folder to the guest machine through Oracle VB?

Because as default, on my machine, the guest can't see the host so you have to share the folder. Then the folder should be available as a network drive so you can mount it from Places->Network or it should auto mount it.

Andy

Norbert Hoffmann (norb1933) said : #4

Thanks Andrew. I am still stuck. I did share c:\Users within Windows and to the guest machine through Oracle VB. In Ubuntu I installed guest additions. Network shows "Windows Network". When clicked I get "Unable to mount location - Failed to retrieve share list from server". The shared folder icon at the bottom of the VM box window does show c:\Users as shared. On the host machine Network does show "Users" as shared also. Names are spelled correctly.

Norbert Hoffmann (norb1933) said : #5

Thanks Andrew. I am still stuck. I did share c:\Users within Windows and to the guest machine through Oracle VB. In Ubuntu I installed guest additions. Network shows "Windows Network". When clicked I get "Unable to mount location - Failed to retrieve share list from server". The shared folder icon at the bottom of the VM box window does show c:\Users as shared. On the host machine Network does show "Users" as shared also. Names are spelled correctly.

Best delance (olivier-delance) said : #6

You need to manually mount shared disk in Ubuntu. Have a look in Virtual-Box user manual.

Norbert Hoffmann (norb1933) said : #7

Thanks. I don't know how but after fiddling with the network settings of the host computer (Win7) I was able from Ubuntu to connect to it as a server and mount the shared folder "User". This works fine for me.

Norbert Hoffmann (norb1933) said : #8

Thanks. I don't know how but after fiddling with the network settings of the host computer (Win7) I was able from Ubuntu to connect to it as a server and mount the shared folder "User". This works fine for me.

Norbert Hoffmann (norb1933) said : #9

Thanks. I don't know how but after fiddling with the network settings of the host computer (Win7) I was able from Ubuntu to connect to it as a server and mount the shared folder "User". This works fine for me.

Norbert Hoffmann (norb1933) said : #10

Thanks delance, that solved my question.