KVM in Ubuntu 19.10 not working.

Asked by Layke

Hello,

So when I try to create a virtual machine with KVM on Ubuntu 19.04 with a Ubuntu Server 18.04 LTS ISO, I get to a curtin-command failure, specifically curtin in-target or something like that during installation. Does anyone know what's going wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu virt-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Layke
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Ubuntu 19.04 is only supported for one more month
https://wiki.ubuntu.com/Releases

You may want to use this as a catalyst to upgrade to 19.10 for continued support.

Revision history for this message
Layke (layke1123) said :
#2

Will try upgrading in the meantime.

Revision history for this message
Layke (layke1123) said :
#3

Still fails to boot a 18.04 LTS server image via KVM and virt-manager on 19.10.

Revision history for this message
Layke (layke1123) said :
#4

Willing to provide more data if anyone once to take even a casual glance at my issue hopefully! =)

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

"curtin in-target or something like that"
If there are error messages, please provide their full and exact text.

Is this the first time that you try running a virtual system on that host, or do/did other virtual machines work well?

Revision history for this message
Layke (layke1123) said :
#6

It is the first time I have tried using KVM on the system to create a virtual machine. It was previously a Virtual Box Guest OS that I moved to an SSD on another computer to run it on bare metal. I'll provide the logs shortly once I have figured out how to get the logs out of the guest OS that is failing to install the server Ubuntu 18.04 LTS ISO.

Revision history for this message
Manfred Hampl (m-hampl) said :
#7

If this is the first time that virtual systems are run on that hardware, then you should make sure that virtualization is enabled in the system's BIOS. This is a prerequisite for all kinds of virtualizations and may be disabled if not needed.

Revision history for this message
Layke (layke1123) said :
#8

I should clarify, virtualization is indeed enabled.

Revision history for this message
Manfred Hampl (m-hampl) said :
#9

Then we need the error messages.

Revision history for this message
Layke (layke1123) said :
#10

So error messages have stopped and I can't reproduce them unfortunately. Having networking issues still, but the previous error is gone. I will say problem solved unless it happens again. Any help though on figuring out how to get error messages out of a KVM guest OS would be nice for future knowledge though.

Revision history for this message
Layke (layke1123) said :
#11

Closing problem.

Revision history for this message
Layke (layke1123) said :
#12

Just an update, finally managed to get this working. Turns out there's some conflict with the default network created by libvirt. After doing the following commands and then creating a new network with a different name, internet on the guest OS started working again. Adding just in case this helps someone else in the future.

virsh net-destroy default
virsh net-undefine default
service libvirtd restart

Once the above commands have been executed, just open virt-manager and create a new network, I used all the defaults provided, and my guest OSes started being able to connect to the outside world.

Revision history for this message
Layke (layke1123) said :
#13

Just an update, finally managed to get this working. Turns out there's some conflict with the default network created by libvirt. After doing the following commands and then creating a new network with a different name, internet on the guest OS started working again. Adding just in case this helps someone else in the future.

virsh net-destroy default
virsh net-undefine default
service libvirtd restart

Once the above commands have been executed, just open virt-manager and create a new network, I used all the defaults provided, and my guest OSes started being able to connect to the outside world.