Remote Desktop Viewer not working for Internet connection

Asked by John Rose on 2009-07-08

On Jaunty for both machines: Remote Desktop Viewer works OK when both laptop & netbook are connected to the same router. However, no success when the laptop is connected to a router linked to one ISP and netbook is connected to another router linked to another ISP i.e. true remote connection.

I've allowed port 5900 in both Ubuntu firewalls. First router is UPNP enabled and has RemoteDesktopViewer on port 5900 (with firewall rule for laptop LAN ip address). Second router is UPNP enabled. In Firewall Configuration (i.e. gui for gufw), I've allowed port 5900 incoming on laptop.

I've tried ipaddress::5900 with ipaddress as first router address & as second router address: both give window stating connection was closed..

Is it a problem with jaunty or what should I be using for Host in Remote Desktop Viewer?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vino Edit question
Assignee:
No assignee Edit question
Solved by:
John Rose
Solved:
2009-07-09
Last query:
2009-07-09
Last reply:
2009-07-09

Using the router settings, usually you need to redirect the incoming 5900 port packet to the 5900 port of the internal pc.

Hope this helps

Jeruvy (jeruvy) said : #2

To help clarify what marcobra stated, you need to PORT FORWARD your internal machine IP address and port to the router's EXTERNAL IP (public) address and port. See this link for details.

http://portforward.com

John Rose (johnaaronrose) said : #3

I had done the Port Forwarding (on the router setups OK) & Firewall Configuration OK. I forgot to mention that I used Remote Help Assistant (downloaded as deb from Launchpad) on both PCs which then called Remote Desktop Viewer on the laptop. Everything worked once I disabled UPNP on both routers.

Jeruvy (jeruvy) said : #4

Very interesting, I myself dislike UPNP and disable it immediately on all my boxes, and my router does not have it enabled. Good to know this one. Thanks John.