unable to reach remote Desktop

Asked by perezxolote on 2009-03-03

Hi,
I am trying to reach an Ubuntu 8.10 desktop with an other U 8.10 through the internet, both behind a router. The "server" has already been configured and the ports forwarded. In my case (client), I opened vinagre and gave the IP Adress, but I just get a black screen (window). Do I have also to forward ports in my router? Where can I find explicit instructions for it? (I really don't know very well what I am talking about here) Thanks.

Adrian

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vinagre Edit question
Assignee:
No assignee Edit question
Solved by:
perezxolote
Solved:
2009-03-19
Last query:
2009-03-19
Last reply:
2009-03-19
Bernd Schlapsi (bernd-sch) said : #1

Are you sure you have configured the right port on the "server"? Which port do you use? I think 5900 is the right one.
On the client side you don't have to configure port-settings on your router.
Through a google-search I found this blog-post: http://p-s.co.nz/wordpress/?p=275. Perhaps this could help you

perezxolote (perezxolote) said : #2

Thank's for the link. Yes, it was 5900. The other thing I noticed is that, despite I get a "black screen" the name of the host appears at the title bar of the window and I don't get any error message. Is there a way I can find out more precisely where the problem is?

Bernd Schlapsi (bernd-sch) said : #3

Does the other side (server) except your request to share/view the desktop?

Under System > Preferences > Remote Desktop > Sharing they will need to “Allow other users to view your desktop”, “Allow other users to control your desktop” but not “Ask you for confirmation”.

perezxolote (perezxolote) said : #4

aha! That could be the issue. I'll try this evening (server in Mexiko-client in Germany!) also with the instructions of the site you gave me and report then if it worked.

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

perezxolote (perezxolote) said : #6

I solved the issue at the End creating a virtual network with Hamachi. Vinagre works very well this way. I wasn't able to do it otherwise. Thank's for the support any way and sorry for the late answer.

perezxolote (perezxolote) said : #7

I'm marking the proble as solved.