How to allow remote desktop connections

Asked by Paul Williamson on 2011-05-07

Since upgrading to 11.04 I cannot make a remote desktop connection to Ubuntu from Windows 7 using RDP. Most of the advice I've found starts with the instruction to enable Remote Desktop Connections on the Ubuntu machine by going to System > Preferences > Remote Desktop.

My problem is that I DO NOT HAVE any menu item that leads to Remote Desktop.

How can I get/restore that menu item, OR is there some other way to accomplish the same thing?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vinagre Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Williamson
Solved:
2011-05-08
Last query:
2011-05-08
Last reply:
2011-05-07

press ALT+F2 and run:

rdesktop

you may get luck with restoring your panels with:

gconftool --recursive-unset /apps/panel && killall gnome-panel

You can press CTRL+ALT+T and run it there

delance (olivier-delance) said : #2

If you want to display an Ubuntu screen inside a windows of Windows, type Ctrl+Alt+T and then vino-preferences
Which window manager are you using ?

Thanks to both of you.

As for the missing menu item -- I rebuilt the system with a clean install. That solved that. Although I know a lot about Windows, I'm just beginning with Ubuntu, so I appreciate the tips.

As for connection issue:
I am connecting FROM a laptop running Windows 7 home premium. I have three ways to connect: Windows RDP, TightVNC, and PuTTY. I am connecting TO three Ubuntu boxes, all with 11.04 Natty. All three have xrdp installed. With PuTTY I can connect to all three with a terminal; that's fine. I've gotten to the point where I can connect the desktop on all three machines with either WinRDP OR TightVNC, but not both.

What is still driving me crazy is system2:
I can connect using Remote Desktop -- ONCE. If I close the session, any subsequent attempts to connect hang. (But at that point, TightVNC will work - go figure). If I restart the system, then Remote Desktop will work again, once. I think the problem boils down to: What is stopping that's not supposed to when I close the remote session?

The connection dialog looks like this:
     connecting to sesman ip 127.0.0.1 port 3350
     sesman connect ok
     sending login info to sesman
     --- here's where it hangs. When successful, the dialog continues
     xrdp_mm_process_login_response: login successful for display (cut off by narrow dialog box, can't capture it)
     connecting to 127.0.0.1 5910
     tcp connected
     security level is 2
     password ok
     sending share flag
     .... etc.

However, once Remote Desktop stops working, then TightVNC will work but not vice-versa. The system is a clean install using the server CD then adding ubuntu-desktop (I believe it's Unity). xrdp-sesman.log is empty.

What is truly weird is that system3 is also a clean install, except that the desktop is xfce. On system3 Remote Desktop always works, but TightVNC does not.

I'd still like to figure out what's going on with system2, but at least I have an alternative, so the problem is no longer critical.

I'm marking this "solved" because I have a workaround, but any insight would be very welcome.