Remote desktop to win xp thru VPN

Asked by pedro oliveira on 2010-10-14

I'm trying to connect to a win xp computer at the office with vpn from home.

in a remote windows machine it's very easy . i just put the gateway, username, password and use pptp in vpn connection and I can use remote desktop with the remote machine IP address.

in Ubunto, i can succesefully login with vpn connection, but remote desktop doesn't connect. pinging the remote computer doesn't work also. ( in windows, it did).

Should I make any additional configuration? can I see a log that explain why the vinagre Remote desktop does not work?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vinagre Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2010-10-15
Last query:
2010-10-15
Last reply:
2010-10-15

This question was reopened

are you pinging by IP or name?

pedro oliveira (pedropo) said : #2

yes I am pinging by ip. In windows it only works with ip.

ok so pinging by IP fails, does the IP you get in the VPN match the iP address you get on your LAN?

pedro oliveira (pedropo) said : #4

no, my office machine as static ip.

it never is equal to the vpn ip that is issued to me.

could it be a port issue? my vpn provider, a watchguard xcore, uses tcp port 1723.

or maybe firewall in ubunto. I just installed it and didn't change a thing, and honestly dont's know how.

if the vpn succeeds in connecting its not a port issue.

When the VPN is connected can you give the output of:

ifconfig

Thanks

pedro oliveira (pedropo) said : #6

here it goes

pedropo@pedropo:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1e:68:66:23:b4
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:28 Base address:0xe000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:117 errors:0 dropped:0 overruns:0 frame:0
          TX packets:117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10001 (10.0 KB) TX bytes:10001 (10.0 KB)

ppp0 Link encap:Point-to-Point Protocol
          inet addr:192.168.1.251 P-t-P:192.168.1.250 Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1400 Metric:1
          RX packets:1164 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1079 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1151276 (1.1 MB) TX bytes:93875 (93.8 KB)

wlan0 Link encap:Ethernet HWaddr 00:1f:3c:50:6a:13
          inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21f:3cff:fe50:6a13/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:1441 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1623 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1250827 (1.2 MB) TX bytes:219681 (219.6 KB)

This is why, your LAN has the SAME subnet as the VPN. Both use 192.168.1.0/24 which WON'T work. If you change the address scheme of your router to 192.168.2.0/24 or something like that, then any traffic for the LAN and the web will use the LAN but anything headed for the 192.168.1.0/24 will travel down the VPN

You need to change your reouters settings. You have a network address clash, tehOS will see a packet destined for 192.168.1.251 but due to routing will assume this is a PC on your HOME LAN and will simply give the packet to the router for the next hop. This is not the case however

pedro oliveira (pedropo) said : #8

thanks i'll try it out this evening.

In windows shouldn't this problem ocur also? the IP from remote and local PC's are in the same subnet also.

True but they probably (as part of the software) added a static route for the IP to use the virtual device. I am not conversant with the route command and it is far easier to just change your subnet on your router. Your network usage will not be altered as DHCP will apply the new settings to the PCs next time DHCP is requested (obviously if you use static IP for any devices, you will need to change these BEFORE modifying the router)

pedro oliveira (pedropo) said : #10

well, changing the IP range on the router did it.

I can remote desktop with rdesktop :), but vinagre does the same thing.

ping works fine also.

what could be the reason?

Simple routing, you have 2 physical networks with the same network address (as I said earlier). By changing the address of YOUR network you have made a clear definition between the addressing so the network infastructure knows where to shove the data.

You may find that the windows client sets up a route to the remote IP but if you had a PC with the same 192.168.1.251 IP it would not be contactable.

This clash of network addressing is common but (as you can see) is easy to fix.

pedro oliveira (pedropo) said : #12

but why doesn't vinagre works? rdesktop does!

if you are connecting to a windows network and need remote desktop then rdesktop is what you need, vinagre is a VNC client

pedro oliveira (pedropo) said : #14

:P

sorry. at the end all is fine & working

thank you for all the help