Vim crashes if .vimrc present (Karmic)

Asked by rogmorri

When I have a .vimrc file, vim crashes. This happens in Karmic, up to date as of 2009-10-19. If this is a vim or a lib problem, I can't imagine that I'm the only one seeing this, so I wonder what might be set up wrong.

Does anyone else see this?

rsm@hina:~$ rm .vimrc
rsm@hina:~$ vim
rsm@hina:~$ touch .vimrc
rsm@hina:~$ vim
Vim: Caught deadly signal ABRT
Vim: Finished.
Aborted (core dumped)

Question information

English Edit question
Ubuntu vim Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
rogmorri (frontporsche) said :

I tried this again on a fresh install, from yesterday's daily build, and I don't observe this problem anymore.

Revision history for this message
Elmer Rivera (erivera) said :

i also experienced this, using vim-7.2.tar.bz2

Revision history for this message
MK (halfcountplus) said :

I am having the exact same problem using a source built vim.

Revision history for this message
MK (halfcountplus) said :

Turns out this was a bug in vim and patched subsequent to 7.2. See the last post in this thread:
for instructions.

Revision history for this message
Steve Sauls (steve.sauls) said :

I tried this and can not confirm this in 10.04. But your vimrc file is located at /etc/vim/vimrc. If you are using the vim package from synaptic package manager. I would strongly suggest using the supplied package and edit the /etc/vim/vimrc file to your liking.