vi editor is not working

Asked by Niju

I installed ubuntu 7.10, after that i tried to work with vi editor, its going into the editor but if i press INSERT its not going to insert mode, if i use any arrow keys its showing some other characters., its not accepting g++ command, i tried to use $ sudo apt-get install vim, it showing vim package not found, how i solve this please help me.

Question information

English Edit question
Ubuntu vim Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Arnaudus (a-lerouzic) said :


For your first problem: you are expecting vim commands to work with vi, which is usually not the case. As far as I remember, Ubuntu 7.10 provides the "real" vi, and not vim. In the original vi, the insert command is "i" (the letter), and "arrows" are j and k --not very convenient, admittedly. Later Ubuntu versions provide vim as a replacement for vi, which makes a lot of sense.

For your second question, if you had run "apt-cache search vim", you would have noticed that the package name for vim in old Ubuntu is vim-common.

Hope this helps!

Revision history for this message
Sam_ (and-sam) said :

Can you help with this problem?

Provide an answer of your own, or ask Niju for more information if necessary.

To post a message you must log in.