VIM syntax highlight inconsistency

Asked by TCrabtree

I have two Ubuntu 10.04 servers, installed from the same .iso file with the same options. Yet, on one server, the syntax highlighting is completely different than the other. With :set syntax=on, so much is underlined and grayed out that files are nearly unreadable. On the other, syntax highlighting works perfectly. I have tried creating .vimrc files and loading .vim files for highlighting, but nothing seems to work. Whenever I turn syntax on, it's still a mess of underline and gray. I've checked /root and there is no .vimrc file or anything different from the other server where syntax highlighting works as expected.
What can I try now?
As I said, I've tried creating /.vim/syntax/filename.vim and creating a .vimrc file, but nothing works.
Thanks for any help with this problem.

Question information

English Edit question
Ubuntu vim Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
mycae (mycae) said :

Are you using vim-minimal, or have you installed the full vim?

What is the file type you are highlighting? (check :set filetype)

Revision history for this message
Hilario J. Montoliu (hjmf) (hmontoliu) said :

Hi TCrabtree,

Does that happen through an *-term (xterm, gnome-terminal, etc; for example through ssh) or does it happen in a tty?

If it's the latter it may be an issue with your screen setup rather than a vim issue.


Can you help with this problem?

Provide an answer of your own, or ask TCrabtree for more information if necessary.

To post a message you must log in.