14.04 New GNOME in KVM video issues

Asked by Doug Smythies on 2014-01-25

I work on the official Ubuntu Documentation, and run a 14.04 Ubuntu Desktop as a VM on my Ubuntu 12.04 server. I need to go back and forth between Unity Desktop and GNOME desktop. About a week ago, and synchronous with some GNOME updates, the GNOME desktop has issues. The screen is wrong, and an app window is clipped and not movable. Unity Desktop works fine (well mostly, there seemed to a regression for a day where nothing worked, similar to a few weeks ago, but that seems to be O.K. now).

Note that I use the vmvga driver, because and at least for me the cirrus driver does not work properly. As far as I could determine past issues with the vmvga driver have been fixed.

GNOME doesn't seem to realize the video display resolution settings. There are also entries in /var/log/libvirt/qemu/desk_ss.log, such as:

vmsvga_update_rect: update width too large x: 100, w: 846

Such entries are not present when logging on with Unity Desktop.

My system was using vgabios 0.6c-2ubuntu3, but I have now upgraded to 0.7a-3ubuntu3.
I have also tried kernel 3.13

I realize it may be incorrect to post this under the "vgabios" package, but I think at least some knowledgeable people might see it. I have struggled to identify the real root issue or package.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu vgabios Edit question
Assignee:
No assignee Edit question
Last query:
2014-01-27
Last reply:
2014-01-26
Doug Smythies (dsmythies) said : #1

My 12.04 server is headless, I only use VNC for the GUI Desktop screen, and ssh for a cli terminal.

Typically, I am trying to use a 1680X1050 display resolution on my VM as that fits nicely inside my client desktop of 1920X1200.

If I switch to the cirrus driver, then the new GNOME does work, but the video display is terrible and only minimal resolution is available (for both Unity and GNOME Desktops).

Unity isnt a desktop. It is a shell for Gnome. When you use Unity you are running it on top of Gnome. Gnome is not a replacement for Gnome.

Why are you using VNC on a server? What are you connecting to the server to achieve? What do you do on the remote system via VNC?

Doug Smythies (dsmythies) said : #4

I'm not using VNC on a server. I am using VNC from another computer on my lan to communicate with my Desktop VM running on my server. It is the only way I know how to do it. The only Ubuntu Desktop I run is this VM one. I have several ubuntu servers, though.

O.K., so I have the terminology wrong. What I was trying to say that Unity is working fine, but the New GNOME, meaning the one that the system upgraded to about a week ago, is not. As mentioned in my priginal post, things were working fine before those updates. What I am looking for with this question is why not and how to make it so that it works, or where to file a bug report, if that is what it turns out to be.

Then i suggest you report a bug.

What do you do on the remote server once you connect using your VNC client?

Doug Smythies (dsmythies) said : #6

Thanks for your replies. I would file a bug report, but it is not clear to me what to file it under.

I do not understand the question. Once I connect to the VM desktop via VNC I use it as an Ubuntu desktop computer (when it works). In particular right now, I log in under the Ubuntu default desktop environment and compare the development version of Ubuntu docs with the actual 14.04 desktop environment. I also log in under the GNOME desktop environment and compare GNOME help with the actual desktop environment. Issues with the conditionals (Unity or GNOME) within common docs and issues with yelp-tools and what get displayed is a long story that I don't really want to get into.

Doug Smythies (dsmythies) said : #7

I had another VM desktop, that had not been used since November 17th. I upgraded it today, and have the same results/issues after the upgrade.
I'll file a bug report under xorg.

Can you help with this problem?

Provide an answer of your own, or ask Doug Smythies for more information if necessary.

To post a message you must log in.