no package in Ubuntu 20.04 LTS

Asked by Adrian on 2020-11-19

Hello all,

Is there any technical reason why there isn't package for Ubuntu version 20.04 LTS ? When looking on dependencies here https://packages.ubuntu.com/groovy/varnish-modules I see that there isn't varnishabi-11.0 available. I can find only version 9.0 from packagecloud mirror.

# apt-cache policy varnishabi-*
varnishabi-strict-9f8588e4ab785244e06c3446fe09bf9db5dd8753:
  Installed: (none)
  Candidate: (none)
  Version table:
varnishabi-9.0:
  Installed: (none)
  Candidate: (none)
  Version table:

TLDR
I see that varnish ver. 6.5 can be installed on Ubuntu 20.04 but varnish-modules cannot -> https://packagecloud.io/varnishcache/varnish65. What can I do about it ? Should I build it from this branch https://github.com/varnish/varnish-modules/blob/6.5/CHANGES.rst ?

Thx

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu varnish-modules Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-27
Last reply:
2020-12-13
Adrian (findmyname666) said : #2

Thx for very useful response :)

Furthermore I see that required version of libvarnishapi-dev (>= 6.4.0~) isn't available in 20.04 https://salsa.debian.org/varnish-team/varnish-modules/-/blob/master/debian/control. So it should be build as well separately.

Adrian (findmyname666) said : #3

It seems that libvarnishapi-dev conflicts with varnish-dev from packagecloud mirror. Therefore I expect their are interchangeable ....

Manfred Hampl (m-hampl) said : #4

Looking at https://launchpad.net/ubuntu/+source/varnish-modules/+publishinghistory my assumption is that at the time of publication of Ubuntu 20.04 there was no functioning varnish-modules package available, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939932
The problem was solved in Debian only in May 2020, which is after focal's publication date.

Where do you see varnish 6.5 for Ubuntu focal?
The Ubuntu repositories have only version 6.2.1-2 (but that is not related at all to the missing varnish-modules package)

Maybe it is possible to manually install the packages varnish (6.4.0-3), libvarnishapi2 (6.4.0-3) and varnish-modules (0.16.0-2) for Ubuntu groovy on focal as a workaround.

Adrian (findmyname666) said : #5

Hi Manfred,

Varnish package for focal is hosted on packagecloud https://packagecloud.io/varnishcache/varnish65. I assumed that it is maintained by Varnish team. Either way I was able to build the same package on the focal but I had to do a few adjustment:
- replace one build dependency
- add one gcc flag -Wno-error=deprecated-declarations because on focal it failed on vmod_bodyaccess.c:205:2: error: 'VSB_delete' is deprecated [-Werror=deprecated-declarations]. I assume that it is due to different gcc version on the focal in comparison to groovy.

Adrian (findmyname666) said : #6

Update - regarding deprecated declaration i mentioned in the previous messages - I noticed that Debian maintainers patched their varnish-module package and they fixed deprecated declarations see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=971142.

Adrian (findmyname666) said : #8

I think deprecated declarations mentioned above are bug/issue actually.

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.