Need fix for Canon MF5770 printer/scanner on 16.03

Asked by John A Peters on 2017-12-13

I have updated the O/S and updated Cups to 2.2.4 and still cannot get the Canon MF5770 to print. It will scan with VueScan and I can ping the printer. The printer works fine on Windows 7 64bit on the same machine. I have the MF5770 PPD file. Ubuntu says the file is sent to the printer and printed, but nothing happens.

AMD 64, 16Gb RAM, 6 TB of disk.

Any ideas:??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
John A Peters
Solved:
2018-07-05
Last query:
2018-07-05
Last reply:
2017-12-13

Have you checked the Canon website for drivers

John A Peters (johnpeters) said : #2

After HOURS of experimentation and study, I have the Canon MF5770 all in one printing on Ubuntu 16.x

1. Use an Ethernet connection, (USB will not work reliably)

2. download the PPD file from my dropbox: https://www.dropbox.com/s/ie587mqpn57uw2u/mf5770.ppd?dl=0

3: install printer driver using the PPD file options.

the fax side never worked, so I purchased SCANVUE.
Cheers,
John

FYI, Canon does not support this printer for Linux.

Scanning is working with http://www.sane-project.org/man/sane-pixma.5.html
Could you please share how you install it using network connection?

I fond it