can not mount external drive

Asked by jacek on 2009-02-04

Hi,

I just got a new samsung 2,5" external hard drive and when I plug it in, my Ubuntu (8.04) can not mount it. The error is: Can not mount volume.
unable to mount volume "nowy"

please advice,
Jacek

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
jacek
Solved:
2009-02-07
Last query:
2009-02-07
Last reply:
2009-02-05
Sam_ (and-sam) said : #1

Hi,
please check syslog for related error messages to find out why it can't be mounted, because usually Ubuntu mounts automatically.
System -> Administration -> System Log ##Log viewer for various logfiles detailing activity on your machine.
Please note,
https://help.ubuntu.com/community/Mount/USB

jacek (jacekb57) said : #2

Hi Sam,

those are the log messages that i got. i am still reviewing the link that you proviuded. please advice if you see anything strange from those messages:

Feb 4 22:32:25 jacekb01-desktop kernel: [ 148.668217] usb 2-5: new high speed USB device using ehci_hcd and address 4
Feb 4 22:32:25 jacekb01-desktop kernel: [ 148.728704] usb 2-5: configuration #1 chosen from 1 choice
Feb 4 22:32:25 jacekb01-desktop kernel: [ 148.728975] scsi5 : SCSI emulation for USB Mass Storage devices
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.032415] scsi 5:0:0:0: Direct-Access SAMSUNG HM251JJ PQ: 0 ANSI: 2 CCS
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.033195] sd 5:0:0:0: [sdf] 488397168 512-byte hardware sectors (250059 MB)
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.033606] sd 5:0:0:0: [sdf] Write Protect is off
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.034277] sd 5:0:0:0: [sdf] 488397168 512-byte hardware sectors (250059 MB)
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.034673] sd 5:0:0:0: [sdf] Write Protect is off
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.034894] sdf: sdf1
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.052012] sd 5:0:0:0: [sdf] Attached SCSI disk
Feb 4 22:32:30 jacekb01-desktop kernel: [ 151.052123] sd 5:0:0:0: Attached scsi generic sg6 type 0

jacek (jacekb57) said : #3

i tried to follow the link but get stuck here, but I think that the 250 gig drive is seen.

jacekb01@jacekb01-desktop:~$ sudo fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000001

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 6502 52227283+ 7 HPFS/NTFS
/dev/sda2 6503 14404 63472815 83 Linux
/dev/sda3 14405 14598 1558305 82 Linux swap / Solaris
/dev/sda4 14599 38913 195310237+ 83 Linux

Disk /dev/sdf: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x846d8917

   Device Boot Start End Blocks Id System
/dev/sdf1 1 30401 244196001 7 HPFS/NTFS
jacekb01@jacekb01-desktop:~$ sudo mkdir /media/external
jacekb01@jacekb01-desktop:~$ sudo mount -t vfat /dev/sdf /media/external -o uid=1000,gid=100,utf8,dmask=027,fmask=137
mount: wrong fs type, bad option, bad superblock on /dev/sdf,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Using terminal, please try this:

sudo ntfs-3g /dev/sdf1 /media/external

and to get ntfs-3g options and manual:

man ntfs-3g

Hope this helps

Sam_ (and-sam) said : #6

Hi jacek,
messages look ok.
The crucial was your command
##sudo mount -t vfat /dev/sdf

According to this output:
Device Boot Start End Blocks Id System
/dev/sdf1 1 30401 244196001 7 HPFS/NTFS

it says neither vfat nor sdf, like you typed.
It's a NTFS filesystem on partition sdf1.

Ubuntu includes already packages to read+write NTFS.
note: man mount
http://manpages.ubuntu.com/manpages/intrepid/en/man8/mount.8.html

jacek (jacekb57) said : #7

thanks guys, much apppreciated.