Ubuntu 8.04 - can't mount my extra hard drive, also i can't mount usb drive, i get you are not privileged to mount the volume (HD)

Asked by Steveo on 2009-01-23

Ubuntu 8.04 - can't mount my extra hard drive, also i can't mount usb drive, i get you are not privileged to mount the volume (HD), also i have a 4 port usb card, Ubuntu 8.04 doesn't see it, but it does see my sandisk memory card reader for camera. Also not seeing my questions on the launchpad, so i know i must have a problem.

I think windows locked the drives. Thanks for all answers.

Steve

0

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
h2g2bob
Solved:
2009-01-25
Last query:
2009-01-25
Last reply:
2009-01-25
Steveo (strykersrealm) said : #1

Ok i see my question this time..... My windowsXP does not work that well so i use Ubuntu 8.04 all the time. I like windows, but this OS is fun and better in my mind. I do a lot better in windows. But i really want to learn Ubuntu, but i feel dumb ... lol.

Steveo (strykersrealm) said : #2

i have downloaded and used disk manager, i can use it well enough. Still not able to unlock the drives and mount them. I have a usb drive which i can see and burn a dvd data disk. But when i go to delete folders they have a lock and can not delete. The hard drive internal is formatted NTFS and has two partitions and the external usb drive is formatted NTFS also.

Best h2g2bob (d-j-batley) said : #3

This is due to the file system on the disk being damaged. When Linux detects the file system is damaged, it automatically makes it read-only.

You can solve this by:
1. Open a terminal window with Applications > Accessories > Terminal
2. Insert the disk. It will automatically become mounted. Mounted means the files on the disk are viewable and (normally) editable.
3. In the terminal window type "mount | grep hal" and press enter. This lists the disks mounted by hal (ie: all external disks). You should see exactly one item starting "/dev/sdXX on /media/YYYY ...."
4. Unmount the disk by right-clicking on the desktop icon for the disk (or icon on the left of the file browser) and selecting "unmount". You should always unmount disks before removing them (this is the same as Windows' "safely remove hardware" feature).
5. In the terminal window type "sudo fsck.msdos -afV /dev/sdXX" replacing /dev/sdXX with the value from step 3. This will check the drive for errors and automatically fix it. You will need to enter your password.
6. Remove disk and re-insert it. It should automatically mount again, and you should be able to edit the files.

Steveo (strykersrealm) said : #4

Thanks h2g2bob, that solved my question.

I tried your commands and it did not work. I initially had a hard drive with some screwed up jumper setting and I think I have corrected it. Still I can't mount and it tells me I am not privileged to mount the drive..please helps....its an internal hard drive..