Unmountable RAID volume

Asked by s_raiguel on 2008-11-08

I can't seem to mount my RAID 0 volume, which is Intel's BIOS-based AHCI RAID manager. Here's what happened: I freed up an extra harddrive (not a RAID volume) in my Dell, and decided to install Ubuntu 8.1 on it, with XP residing on the primary, RAID drive. Since I'd had problems before installing on a second hard drive which resulted in neither Windows nor Unbuntu booting, I decided to unplug both RAID member drives so that the Ubuntu installation couldn't try any monkey business with them. When all was done, both Windows and Ubuntu booted nicely by selecting the boot drive from the BIOS boot options. The problem was, the Ubuntu installation didn't see and wouldn't mount the RAID NTFS volume, so that I can share data between the operating systems. The RAID volume is apparently active, since FDISK -l shows:

   Device Boot Start End Blocks Id System
/dev/sda1 1 6 48163+ de Dell Utility
/dev/sda2 * 7 60395 485074642+ 7 HPFS/NTFS
/dev/sda3 60396 60787 3148740 db CP/M / CTOS / ...

which are all partitions on the RAIDed drive. Also, dmraid -r gives

/dev/sdb: isw, "isw_diiiejfeia", GROUP, ok, 488281248 sectors, data@ 0
/dev/sda: isw, "isw_diiiejfeia", GROUP, ok, 488281248 sectors, data@ 0

Where "isw" indicates Intel software RAID, and 488 gig is about the size of half-terabyte drive. Also, dmraid -ay says that the array is already active:

RAID set "isw_diiiejfeia_ARRAY" already active
RAID set "isw_diiiejfeia_ARRAY1" already active
RAID set "isw_diiiejfeia_ARRAY2" already active
RAID set "isw_diiiejfeia_ARRAY3" already active

Where ARRAY1,2, and 3 are presumably the three partitions on the RAID drive.

However, there is no mention of /dev/sda2 (the main, NTFS partition) in /etc/fstab.conf, which has only these entries

# Entry for /dev/sdc1 :
UUID=419a3127-33b3-41ee-b346-1852839e0ac2 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sdc5 :
UUID=752cc207-4020-484d-bf62-a37c1026362e none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

So, I'm guessing that I need to add a reference to /dev/sda2 by editing fstab, to be able to mount this partition but how do I get a "UUID" for it, and what parameters should I give?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Wyatt Smith
Solved:
2008-11-08
Last query:
2008-11-08
Last reply:
2008-11-08
Wyatt Smith (wyatt-smith) said : #1

To find UUID open a terminal and type

sudo blkid

You may need to mount through /dev/mapper/

For example if sda2 is your windows partition and fstab entry would look like

/dev/mapper/isw_diiiejfeia_ARRAY21 /media/WINDOWS ntfs-3g defaults,uid=1000,locale=en_US.UTF-8 0 0

Hope this helps

Best Wyatt Smith (wyatt-smith) said : #2

Dam I hate not having edit. Sorry about the typo - it should be

/dev/mapper/isw_diiiejfeia_ARRAY2 /media/WINDOWS ntfs-3g defaults,uid=1000,locale=en_US.UTF-8 0 0

s_raiguel (raiguel) said : #3

Dang! That worked! I added that line to fstab,conf then the only additional thing I had to do was create a /media/WINDOWS directory and it mounted immediately, and there were all my files. Thanks a bundle for taking the time to help me out.