Hard disk mount info needed - Ibex

Asked by Simon Furey on 2008-11-02

Hi
I don't have much experience of Linux stuff underneath the covers, which explains the mess I am now in. I have a second hard drive with two partitions that I wanted to mount permanently, instead of having to mount them every time I start up. (they contain all my data, so I can change OS without touching the data). I used the disk mounter which gave me the option of typing in the mount point for on of the partitions, so I did, just to see if it would force a permanent mount. Instead, what it did was complain about my invalid syntax ("Cannot mount volume: Unable to mount the volume: mount point cannot contain the following characters...") and now refuses to mount the said partition. I can still mount the other one that I didn't mess about with. I am quite happy to hack the file that contains the erroneous text that I put in, but I don't know what it's called or where it is. I thought it might be /etc/fstab, but it isn't. Any clues, please? Otherwise I'll have to reinstall (no big deal; I only just installed it).
Incidentally, how do I mount these partitions permanently?
Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Simon Furey
Solved:
2008-11-02
Last query:
2008-11-02
Last reply:
Simon Furey (simon-furey) said : #1

This is very similar to the problem reported as a bug in Hardy Heron, with the reference http://ubuntuforums.org/showpost.php?p=5530231&postcount=44. So obviously the bug has not been cleared in Intrepid Ibex. Nevertheless, following the advice in that article solves the problem, although one extra step is needed.

First, you mount the partition manually in a terminal window with (in my case): sudo mount -t ext3 /dev/sdb2 /media/disk2

Second, you right-click on the new icon on the desktop, select in the new window Properties, then Settings, and then clear the fields revealed. Finally, click Close

Third (and this is the important new bit), you have to unmount the partition manually with (in my case) sudo umount /dev/sdb2 -l

The -l is important.

As for my other question, I have found that I can force the partitions to mount automatically simply by putting the disk mounter on the panel at the top (right-click on panel, select "add to panel"). This seems a bit odd to me, so if there's a better way of doing it, please let me know.

Cheers
Simon