How to access Windows when in Xubuntu

Asked by strikey on 2008-09-21

I have thought about going over to Linux (from Windows XP)
for some while now and in view of the positive comments made about
 it, I downloaded Xubuntu (8.04) and ran this from a CD.

The first thing that I noticed that seemed to be missing was
the facility to access Windows on the C: drive (on Windows =
'My computer'). I would have thought this was a very common
action and was therefore surprised that this was not automatically
included in Xubuntu.
On reading files about this subject on the WWW, I tried some of
the instructions listed, in the termninal mode, but had no success
whatsoever. Most of the 'answers' given to queries are
referrals to yet more webpages and I feel as if I am in pursuit of the
holy grail rather than a piece of info on a simple action on a PC.

In sum, all I want to do is to be able to read/access the files in Windows.
Can anyone advise what I have to type to enable this?
My PC has a floppy (A:), a hard drtive (C:) and a CD/DVD drive (D:)

I have tried some of the suggestions made on this forum, e.g.,

[1]'If you go to "Places" > "Computer" don't you see a something labeled as "xx GB Media"'

In my case, if I go to 'Places', I get:
ubuntu
Trash
Desktop
File system
Floppy drive,

and there is nothing listed as 'Computer'

[2]
'Go to https://help.ubuntu.com/community/AutomaticallyMountPartitions'

Ye gods. I am only trying to access Windows, not find a cure for global starvation!
Why is such a simple action so involved and takes on 'hit or miss' process in Xubuntu?
I cannot even begin to work out what I should do from this page.

[3]
'Type ubuntu@ubuntu:~$ sudo mount -nt vfat /dev/hda1 / mnt/windows'

I did this:

Usage: mount -V : print version
       mount -h : print this help
       mount : list mounted filesystems
       mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ... : mount all stuff from /etc/fstab
       mount device : mount device at the known place
       mount directory : mount known device here
       mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
ubuntu@ubuntu:~$ mount hda1
mount: can't find hda1 in /etc/fstab or /etc/mtab
ubuntu@ubuntu:~$

Once again, it doesn't work. Moreover, what should be a simple task (and is
on other OS) appears to become a very time-consuming quest on xubuntu?

Can anyone help with this? And if you can, please keep it **VERY VERY SIMPLE**

Thanks!

David

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
strikey
Solved:
2008-09-21
Last query:
2008-09-21
Last reply:
2008-09-21
Xero Xenith (xero-xenith) said : #1

Try this: (but don't type the $ sign)

$ sudo mkdir /media/Windows
$ sudo mount /dev/sda1 /media/Windows

If that doesn't work, do this as well:

$ sudo mount /dev/hda1 /media/Windows

...and post the results. :)

strikey (strike-x321) said : #2

Thanks. Still no joy though..

ubuntu@ubuntu:~$ sudo mkdir /media/Windows
ubuntu@ubuntu:~$ sudo mount /dev/sda1 /media/Windows
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sda1 /media/Windows -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sda1 /media/Windows ntfs-3g force 0 0

ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ mount -t ntfs-3g /dev/sda1 /media/Windows -o force
mount: only root can do that
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ sudo mount /dev/hda1 /media/Windows
mount: special device /dev/hda1 does not exist
ubuntu@ubuntu:~$

--------------------------------------------------------------------------------------------------
I also tried:
------------------------------------------------------------------------------------------------

ubuntu@ubuntu:~$ sudo apt-get install ntfs-config

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  ntfs-config
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 42.5kB of archives.
After this operation, 442kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com hardy/universe ntfs-config 0.5.5-0ubuntu1 [42.5kB]
Fetched 42.5kB in 0s (156kB/s)
Selecting previously deselected package ntfs-config.
(Reading database ... 97511 files and directories currently installed.)
Unpacking ntfs-config (from .../ntfs-config_0.5.5-0ubuntu1_i386.deb) ...
Setting up ntfs-config (0.5.5-0ubuntu1) ...

ubuntu:~@ubuntu:~$ gksudo ntfs-config

-----------------------------------------------------------------------------------------------------------------------
I then saw a box headed ntfs-config with
-----------------------------------------------------------------------------------------------------------------------

Add Device Mount point
[Box] dev/sda1 <click here to add a mount point>

----------------------------------------------------------------
I put a tick in the box, I added a name - 'Windows' at the end of
the line, so it then read:
[Box- ticked] dev/sda1 <click here to add a mount point> Windows

I then clicked and received the following:
---------------------------------------------------------------

Mounting /media/<Click here to set a mount point> Windows failed.
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:
Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:
            mount -t ntfs-3g /dev/sda1 /media/<Click here to set a mount point> Windows -o force
    Or add the option to the relevant row in the /etc/fstab file:
            /dev/sda1 /media/<Click here to set a mount point> Windows ntfs-3g force 0 0
----------------------------------------------------------
And there is still no sign of Windows being mounted...

David

strikey (strike-x321) said : #3

Cancel my earlier msg!
Problem solved.

I was looking for Windows in the 'Places' listing.
I found it (eventually) in

File System - Media - Windows.

Phew!

Thanks very much for your time and patience. I will now persevere!

Best wishes

David