I installed Ubuntu edgy, cannot access hda windows

Asked by Patrick Macwilliam on 2007-01-02

I installed Ubuntu edgy 6.10 but I cannot access my windows files on hda. The help file suggests open System-> Administration-> Discs. But there is no entry for discs in the drop down, something has altered since the help file was written. Being a newbie I would rather follow this route than start meddling with the config file, just yet. Which item on the drop down should I follow to achieve my aim of getting access to my windows files.I have tried the device manager but I can find no way of mounting this hard disc, all the info I get is that it is not mounted.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Pope 🍺🐧🐱 πŸ¦„
Solved:
2007-01-05
Last query:
2007-01-05
Last reply:
2007-01-05

Yes, you're right the "discs" tool was removed between version 6.06 and 6.10.

What is your disk layout? You have Windows on one disk and Ubuntu on another? Or separate partitions of the same disc?

Matt Thompson (mattthompson) said : #2

I'm not sure of a way to do this using a GUI anymore, but in the terminal it should be fairly easy.

Assuming that the drive is using FAT32 (and that the windows device is at /dev/hda1, if it isn't just replace it with it's true location below) you could do this:

sudo mkdir /mnt/windows #This creates the folder that the
                                                                       #windows device will be mounted in.
sudo mount -t fat32 /dev/hda1 /mnt/windows

It's not exactly what you were looking for but I hope it helps.

Vijay (aivijay) said : #3

If its a vfat filesystem, then you can try to mount it using

sudo mount -nt vfat /dev/hda1 /mnt/windows

and then use the file manager to access your files.

Hope this helps.

Alan,
thanks for your help. I have two hard discs, with windows on drive c/
hda and ubuntu on drive d/ hdb. during installation I did not accept the
partition option but opted for installation on hdb and i wonder if this
has caused the problem. When I go to device manager, hda is recognized
but I cannot find any means of mounting it.
Patrick

Matt Thompson (mattthompson) said : #5

Sorry, I just noticed the typo in mine, that fat32 should have been vfat. Oops.

It sounds like the windows is on the first partition of hda so copying the command vijay posted should work.

Alan,
thanks for your help. I have two hard discs, with windows on drive c/
hda and ubuntu on drive d/ hdb. during installation I did not accept the
partition option but opted for installation on hdb and i wonder if this
has caused the problem. When I go to device manager, hda is recognized
but I cannot find any means of mounting it.
Patrick

Patrick, the following web page details how to mount filesystems, it should explain what you need to do pretty fully, if not come back and ask further questions:-

https://help.ubuntu.com/community/AutomaticallyMountPartitions

Taking my courage in both hands I entered terminal as suggested by Matt Medland and Vijay. and I now have access to my windows files, many thanks. All I need to do now is get to know the system.

Matt Thompson (mattthompson) said : #9

Excellent, good to know you've managed to sort it out. I'm glad to help. :)

strikey (strike-x321) said : #10

I have thought about going over to Linux (from Windows XP)
for some while now and in view of the positive comments made about
 it, I downloaded Xubuntu (8.04) and ran this from a CD.

The first thing that I noticed that seemed to be missing was
the facility to access Windows on the C: drive (on Windows =
'My computer'). I would have thought this was a very common
action and was therefore surprised that this was not automatically
included in Xubuntu.
On reading files about this subject on the WWW, I tried some of
the instructions listed, in the termninal mode, but had no success
whatsoever. Most of the 'answers' given to queries are
referrals to yet more webpages and I feel as if I am in pursuit of the
holy grail rather than a piece of info on a simple action on a PC.

In sum, all I want to do is to be able to read/access the files in Windows.
Can anyone advise what I have to type to enable this?
My PC has a floppy (A:), a hard drtive (C:) and a CD/DVD drive (D:)

I have tried some of the suggestions made on this forum, e.g.,

[1]'If you go to "Places" > "Computer" don't you see a something labeled as "xx GB Media"'

In my case, if I go to 'Places', I get:
ubuntu
Trash
Desktop
File system
Floppy drive,

and there is nothing listed as 'Computer'

[2]
'Go to https://help.ubuntu.com/community/AutomaticallyMountPartitions'

Ye gods. I am only trying to access Windows, not find a cure for global starvation!
Why is such a simple action so involved and takes on 'hit or miss' process in Xubuntu?
I cannot even begin to work out what I should do from this page.

[3]
'Type ubuntu@ubuntu:~$ sudo mount -nt vfat /dev/hda1 / mnt/windows'

I did this:

Usage: mount -V : print version
       mount -h : print this help
       mount : list mounted filesystems
       mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ... : mount all stuff from /etc/fstab
       mount device : mount device at the known place
       mount directory : mount known device here
       mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
ubuntu@ubuntu:~$ mount hda1
mount: can't find hda1 in /etc/fstab or /etc/mtab
ubuntu@ubuntu:~$

Once again, it doesn't work. Moreover, what should be a simple task (and is
on other OS) appears to become a very time-consuming quest on xubuntu?

Can anyone help with this? And if you can, please keep it **VERY VERY SIMPLE**

Thanks!

David

@ strikey

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered question are usually not read from answering people.

Thank you