Ubuntu 14.04 won't boot - error mounting hard drive - "unrecognizable file system"

Asked by electric-durian

Last night my computer froze. I attempted to restart using RSEIUB, which usually works, but didn't this time, so I had to power down manually.

When I tried to reboot I was able to enter my encryption password, but after boot drops to a (initramfs) prompts/busybox. It looked something like this:

>BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.


I used a live usb to boot into trial mode and can't mount the hard drive with my files on it. I get this error:

>Error mounting /dev/dm-1 at /media/ubuntu/b1ece46a-6da3-48cd-9e80-b8e7f530740d: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/dm-1" "/media/ubuntu/b1ece46a-6da3-48cd-9e80-b8e7f530740d"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/mapper/ubuntu--vg-root,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

If it try "mount /dev/sda5 /mnt" I get "mount: unknown filesystem type 'crypto_LUKS'"

I've seen a few other threads, but haven't had any luck yet.

What else can I try?

Question information

English Edit question
Ubuntu util-linux Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Can you see the LUKS array from LiveCD? You can run an fsck from liveCD then. Encrypted LUKS is the most complex file system IMHO. This may not be easy. You can use mount.crypto_LUKS to mount the file system, it won't be sdXY as you are using RAID, it will probably md0 or dm0 but you don't want it mounted to fsck it.

Revision history for this message
electric-durian (jullyfush) said :

Thanks actionparsnip. I'll try this when I get back home and post the results.

Revision history for this message
electric-durian (jullyfush) said :

Thanks actionparsnip, that solved my question.