unable to write to an external USB drive

Asked by joecrabs77 on 2006-11-12

i have a blank 40GB USB external hard drive, but i'm not able to write to it. i can read it just fine, but every time i try to write anything to it i get the error 'Error while copying to "/media/New Volume".' i am the only account user on this machine with a clean install of unbuntu 6.06. when i try to change the permissions, i just get the error 'Couldn't change the permissions of "New Volume" because it is on a read-only disk'. any suggestions?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2006-11-12
Last reply:
2012-03-09
Svilen Vassilev (tarakanbg) said : #1

Well, you mention nothing about what kind of partitions/filesystems you have on this disk. There's a good chance, that the drive is formatted under NTFS (the common WinXP filesystem) which is only readable, but not writeable under Linux. As long as the drive is empty, my advice is to repartition it (using a partitioning software such as gparted, qtparted, etc.) and format it (with the same application) to an ext3 filesystem (for use only under Linux) or to FAT32 filesystem (slower and with some limitations, but usable for reading and writing both under Linux and Windows).

Good luck!

williamts99 (williamts99) said : #2

The most common reason for this issue is that the drive has been formated with the NTFS file system. This is an issue because Microsoft does not want anyone to be compatible with them(they don't play well with others). If this is your issue, you have a few choices.

One choice(and my recommendation) is to use the ext3 file system and enable ext3 support in Windows(if needed) by using the following driver at http://www.fs-driver.org/ I use this method because I do not mesh well with the limitations of the Fat32 file system.

A second choice would be to format the drive with the Fat32 file system. Though there are limitations with this file system, it is read/write compatible with both Windows and Linux. As a side note Fat32 formatting support in Windows 2000 and XP is limited to volumes of 32 GB, so you will have to choose another tool or format the drive through Linux or Mac osX. The main limitation is that you can not have files that are larger then 4GB in size, for my backed up DVD images, this is not acceptable.

Yet another choice that you can choose is the 'living on the Edge' solution. That would be enabling NTFS write support in Ubuntu. Now this is still in a beta stage but seems pretty stable, but you don't want to enable it on a production machine as it is beta, but if you wanted to try it out, here is the link that will help you set that up.
http://ubuntuguide.org/wiki/Ubuntu_dapper#How_to_mount_Windows_partitions_.28NTFS.29_on_boot-up.2C_and_allow_users_read_and_write_access

Hope this helps.

If these comments have solved your problem, please consider marking this request as answered. https://wiki.ubuntu.com/SupportRequests contains useful information about managing your support request.

If you are still having problems, let us know and we'll keep working on them.

Best Regards,

Williamts99

Guillaume ARCHAMBAUD (drarchy) said : #3

Hello,
I have the same problem.
My disk is formated with gparted in ext3.
When I plug it, only root can write, user don't have the permission.

I don't want to insert /dev/sda1 in /etc/fstab, because I have other USB disk.

Thanks,

Steven Wagner (stevenwagner) said : #4

I have the same problem too. My drive is formated ext3. It has only root permissions.

Guillaume ARCHAMBAUD (drarchy) said : #5

Hello,
is someone has found an answer ?
Thanks

Luca Falavigna (dktrkranz) said : #6

Could you please attach the output generated from command "ls -l /dev/sda1" ?

Guillaume ARCHAMBAUD (drarchy) said : #7

archy@virus:~$ ls -l /dev/sda1
brw-rw---- 1 root plugdev 8, 1 2006-12-20 22:12 /dev/sda1

Luca Falavigna (dktrkranz) said : #8

Are you a member of plugdev group? You can discover it by using id command.
Could you also attach the output of mount command after plugging in your USB disk?

Guillaume ARCHAMBAUD (drarchy) said : #9

archy@virus:~$ id
uid=1000(archy) gid=1000(archy) groupes=4(adm),20(dialout),24(cdrom),25(floppy),26(tape),29(audio),30(dip),44(video),46(plugdev),106(lpadmin),110(scanner),112(admin),1000(archy)

If I do 'sudo mount /dev/sda1 /mnt/sda1', I don't see any message.

dmesg output

[ 1595.956535] usb 3-2: new high speed USB device using ehci_hcd and address 7
[ 1596.015820] usb 3-2: configuration #1 chosen from 1 choice
[ 1596.016021] scsi4 : SCSI emulation for USB Mass Storage devices
[ 1596.016096] usb-storage: device found at 7
[ 1596.016098] usb-storage: waiting for device to settle before scanning
[ 1598.236241] usb-storage: device scan complete
[ 1598.237179] Vendor: WDC WD16 Model: 00BB-22GUC0 Rev: 0811
[ 1598.237188] Type: Direct-Access ANSI SCSI revision: 00
[ 1598.238668] SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
[ 1598.239222] sda: test WP failed, assume Write Enabled
[ 1598.239225] sda: assuming drive cache: write through
[ 1598.239835] SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
[ 1598.240388] sda: test WP failed, assume Write Enabled
[ 1598.240390] sda: assuming drive cache: write through
[ 1598.240393] sda: sda1
[ 1598.247881] sd 4:0:0:0: Attached scsi disk sda
[ 1598.247919] sd 4:0:0:0: Attached scsi generic sg0 type 0
[ 1598.457275] kjournald starting. Commit interval 5 seconds
[ 1598.462082] EXT3 FS on sda1, internal journal
[ 1598.462156] EXT3-fs: mounted filesystem with ordered data mode.

Luca Falavigna (dktrkranz) said : #10

You have to launch mount without any parameter.

/dev/hda1 is mounted in NTFS, but dmesg found an EXT3 partition !!!

archy@virus:~$ mount
/dev/hda6 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.17-10-generic/volatile type tmpfs (rw)
/dev/hda1 on /media/hda1 type ntfs (rw,nls=utf8,umask=007,gid=46)
nfsd on /proc/fs/nfsd type nfsd (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sda1 on /media/usbdisk type ext3 (rw,nosuid,nodev)

fdisk output

Disque /dev/sda: 160.0 Go, 160041885696 octets
255 têtes, 63 secteurs/piste, 19457 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 1 19457 156288321 83 Linux

Commande (m pour l'aide):

Luca Falavigna (dktrkranz) said : #12

If your disk is formatted with NTFS, it is a non-trivial operation enabling write support to it.
I think the easiest solution to this issue is using an EXT3 filesystem: there are excellent drivers for that filesystem available for Windows too. You could use Fat32, but I'd rather prefer EXT3.

If you need to have a NTFS filesystem, you could read this page: https://help.ubuntu.com/community/MountingWindowsPartitions

My disk was formatted in NTFS, but now it is formatted in EXT3 (with gparted) .
dmesg and fdisk show that.

It is possible that an config file remember this disk was in NTFS and try to mount it with this filesystem ?

Thanks

Luca Falavigna (dktrkranz) said : #14

I don't think it can be possible. If root can write on it, it means it is writable so it's just a matter of permissions.

This procedure works for me :

1/ mount the USB disk as root
2/ create a dir
3/ change the owner and the group to allow me to write into it
4/ mount this dir as a normal user

Mateusz Łoskot (mloskot) said : #16

I have the same problem on Ubuntu 6.10 with Hard Drive connected to USB.
The drive mounts but only root has write privileges.

I tried various settings in my /etc/fstab like:

/dev/sda1 /media/usbdisk auto user,noauto,rw,exec 0 0

I'm also a member of plugdev:

mloskot:~$ ls -l /dev/sda1
brw-rw---- 1 root plugdev 8, 1 2007-03-08 15:29 /dev/sda1

Finally, a) I changed the mount point to a directory in my HOME and b) I did run
chown -R mloskot:mloskot /home/mloskot/usbdisk after its mounted
and everything works now.
Here is new /etc/fstab:

/dev/sda1 /home/mloskot/usbdisk auto user,noauto,rw,exec 0 0

I plug the drive, it automatically mounts and I can create/write files.
Honestly, I have no idea where was the problem, but it works now :-)

locust (marineworks) said : #17

Hi,
I have the same problem!
'm running an updated gutsy and i'm not able to write on a usb external hard disk
that is ext3 formatted.
i mount it trough the drivemount applet (I see it as new icon) but i get only read permission for user who mounted it
write permission is only for owner (root).
usb flash disks (vfat) had no problems to be mounted readen written , but thy were indicated on the applet by an icon different from the one for the ext3 volume.

is not a tricky for udev because in both cases the device sda(n) created is writable either from the owner than from the group
1) mountig the ext3 volume on usb hard-drive causes the changing of the (group: root) and of the permissions: write is allowed only for the owner.
2) mountig the vfat volume on usb flash drives makes no changes to owner/group and permissions
3) all the volumes are mounted in /media/disk-(n) and .hal.mtab shows the mounting options
(HOWTO to change them?)

I think that this concerns the settings of hal (similar problems for ntfs partitions has been solved on that way) but i didn't found an appropiate guide.
Best regards
David

Christopher (hawkins-sg) said : #18

I have the same problem as well, even I tried to loadd mp4 files onto my psp. I cant do it as I need to log in as root before I can do anything.

Please anyone with solution please advice me

arkmundi (rkerver) said : #19

I have an external Seagate freeagent USB drive that is now mounting OK with read/write permissions intact. Getting it so was a headache ... here I describe the sequence of commands that provided the correction. I'm running gutsy (7.10).

From other threads, we know that USB drives have a hardtime mounting out of the box. Usually for some reason the mount point is not being created correctly, so you have to do it manually, and then change the permissions on it to allow you write to it as follows:

sudo umount /media/disk {unmounts the disk if already mounted}
sudo mkdir /media/disk {a "mount point" is a special kind of directory}
sudo chown -R username:username /media/disk {where username is your username}
sudo cp /etc/fstab /etc/fstab_backup {make a backup for fstab before editing}
sudo gedit /etc/fstab {edit the fstab, including a new line:
   /dev/sdb5 /media/disk ext3 rw,user,noauto 0 0
sudo mount -a {mounts all devices listed at /dev}

The /dev/sdb5 is the partition you want to mount, obtained from:
sudo fdisk -l
It was the mount options that were giving me the headache, as I had tried all sorts of combinations, gleaned from other threads from people having similar problems. Its the "rw,user,noauto" set of options that force permissions for the mounted devices to come from the directory created.

Luca Cavalli (luca-cavalli) said : #20

The automounting problem of ext3/reiser filesystems is still present on my Hardy (I'm a member of plugdev group).
I know how to manually mount the device with user write access, but I would really like to make it work like FAT32/NTFS filesystems (which works quite well, just plug then USB hard disk in and wait a few seconds for a fully readable and writeable access).
I think we need some specific rule in /usr/share/hal/fdi/policy/10osvendor/.

jklasdf (jjj11x) said : #21

For a newly created ext3 partition, you have to run
sudo chown -R username:username /media/drive
where username is your username, and /media/drive is where the external hard disk is automounted to.

http://www.linuxquestions.org/questions/ubuntu-63/ext3-external-hd-auto-mounted-under-root-problem-616572/

Felix (qqq) said : #22

I have an internal drive but the problem I had was very similar, perhaps identical. Perhaps being a usb is not the issue at all.

Problem:
drive mounts ok, read by anybody, can be written only by root. Need to enable user to write

solved by:
line from /etc/fstab
/dev/sda1 /home/username/share ext3 rw 0 0

from terminal
sudo chown -R username:username /home/username/share

for beginners:
mount -a from terminal will unmount and then mount everything ( unless noauto specified ) using contents of fstab so you can check without rebooting to see what fstab does. Use sudo nautilus to enable writing to / bearing in mind the potential damage you can do.

Using Ubuntu 8.04, encryped

@ Felix

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you

katz (kathirnk) said : #24

Can you help with this problem?

Provide an answer of your own, or ask joecrabs77 for more information if necessary.

To post a message you must log in.