Problem first windows start after linux

Asked by speedon on 2013-03-16

I have installed linux 12.10 (first the 32bit one and after the 64).

 I write because since i have installed ubuntu + grab ,a problem arose:

 Frequently, when I start windows (seven 64bit), the OS start without recognising touchpad neither keybord, and with a resolution completely out of phase (640 x480 pixels or something like that) forcing me to force shutdown the PC.
 The only thing I noticed is that if I put the external mouse is sometimes recognized and allows me to restart the pc without forcing shutdown.

The problem shows-up at the first win boot, after a linux boot.
If Win is restarted after another windows boot, the problem not appear.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Anton Kanishchev
Solved:
2013-03-17
Last query:
2013-03-17
Last reply:
2013-03-17

If for whatever reason the linux installation has damaged your windows side, you can try doing a system restore in windows to a previously good point. How did you install ubuntu? As a wubi install or as a dual boot configuration?

speedon (speedon87) said : #2

First of all, thank you for the reply.

The problem appears only when i start win7 after a previous boot of linux...
Rebooting win7 the problem is definitively solved until the next boot of linux.
So I think that is the boot of linux by grub that damage some parameters win7;
damage solved with the successive reboot of win7. I can try with system restore, but maybe is useless, whath do you think?

My notebook is a toshiba A300 with:
- Intel® Core™2 Duo CPU T5550 @ 1.83GHz × 2
- 3 gb of RAM.
- HD with 3 partition (win7, data and ubuntu (+ swap) );

I installed ubuntu in this way:
1)freeing enough space and leaving it unpartitioned.
2)starting live CD and installing ubuntu from it.

Because i figured out that was the 32bit version, I repeated point 2 to install the 64b version.

At PC start i can choose the SO trough grub.

I don't know what Wubi is.

Wubi is when you install ubuntu inside windows (as a program), but I see you have installed as a dual boot, so that is fine.

Could you please perform a system restore(this reverts your windows installation to a previously good state, while not affecting your data, however programs may be uninstalled, it will warn you if that is the case) in windows, this may fix your problems.After that is done, could you boot into windows and run

chkdsk /f /r

In cmd. This will check your hdd for errors, it may take a while, but if some files are corrupted, chkdsk will fix these.
Could you also have a look in event viewer (windows) to see whether there are any critical errors reported.

From your description I see that you have a win7 partition and a data partition along with ubuntu partition, is this correct? If so is the data partition shared between the 2 OS's- I. E. Do you save files from windows and Linux to the same partition?

When exactly do you notice that the resolution is wrong, when windows is starting to boot (windows logo) or when it has actually booted?

Has this fixed your problem?

speedon (speedon87) said : #4

Thank you for the replies,
After many tests, I have finally solved the problem

==> THE PROBLEM WAS IN THE BIOS, I HAVE UPDATED IT AND ALL WORK GOOD

Thank you very much for your help

speedon (speedon87) said : #5

Thanks Anton Kanishchev, that solved my question.