Is my hardware faulty ?

Asked by Anthony Bodin on 2013-01-12

Hello,

I'm having some problems with Ubuntu and I'm starting to think that some part of my hardware is faulty (either the hardrive, the RAM or the graphic card, ...). How can I be sure that my hardware is healthy or not ? and if not, how to identify which part is causing problems ? If I knew, I could ask for a replacement with the warranty. (I bought the PC as barebone and I got the harddrive and the RAM separately).

Here is my situation.

I have a ZOTAC ID41 with a 64Go SSD harddrive (Crucial CT064M4SSD2) and 4Go RAM (Kingston CL7 SO-DIMM)
I installed Ubuntu last year with version 11.10. I installed version 12.04 few months after (sometime around june).
I had no major problems for many months.

Sometime after the summer the system started to freeze repeatedly when I was using XBMC. I solved this by deactivating visualization plugins while listening music (MProject).
After that the system also started to hang after waking up from idle. I could unlock the system and see the desktop but then no application would open : my only choice would be to shutdown the system. But then I would have crash error during the shutting down. I/O request errors that I thought related to harddrive failure. BUt SMART test and diagnostic tools from Ubuntu did not find anything wrong.
This has been happening more and more over the last weeks and I've tried unsuccessfully to install new drivers for the graphic card (Nvidia ION) and even reinstall from scratch Ubuntu 12.04

Today my "wish" would be to know what is exactly the problem so I can get a replacement for the faulty part....

Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Anthony Bodin
Solved:
2013-01-16
Last query:
2013-01-16
Last reply:
2013-01-12

There is a memtest in Grub. Hold SHIFT at boot and let it run for 10 - 15 mins.

Anthony Bodin (anthony-bodin) said : #2

I ran the memtest (it lasted more than 10-15mn) : the test didn't show anything wrong.
Is it testing the RAM or the Harddrive ?

10-15 min of memtest may not be enough, it's best to let it do at least an entire pass and run it overnight if possible.

Another tool that may help is cpuburn (in the repo). That will allow you to stress the CPU (make sure you monitor CPU temp while running it to see the maximum temp your CPU reaches).

I really suspect the GPU based on what you've described, so see if you can reproduce the crash by running anything graphically demanding.

Anthony Bodin (anthony-bodin) said : #4

I found out that my SDD harddrive (M4 from crucial) had a bugged firmware for which Crucial made an updated firmware...
Updating the firmware seems to have solved my issue