ubuntu 12.04 not mounting d:drive and usb disks

Asked by Rajen Varada on 2013-01-11

 i have just installed ubuntu in dual boot with windows 7. ubuntu does not recognise the d: drive and does not mount any usb pen drives.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Rajen Varada
Solved:
2013-01-15
Last query:
2013-01-15
Last reply:
2013-01-15
Warren Hill (warren-hill) said : #1

Firstly are you sure your "d" drive is not being mounted? It won't be called a "d:" drive as that is purely an DOS/Windows concept.

To check open a terminal by pressing CTRL, ALT and T and enter the following command

------------------------------------------------------------------
sudo fdisk -l; mount | grep ^/dev
------------------------------------------------------------------
Enter password when requested. There is no feedback but the password is being accepted just type it and press enter.

Plug your USB stick wait 10 seconds or so for the stick to be recognised and enter the above commands again.

Copy and paste all results back here.

This will tell us what drives your computer can see and if and where they are mounted.

From this we can advise what to do next

Did you install using Wubi, or did you resize your NTFS and install Ubuntu to it's own partition?

Rajen Varada (rajen-varada) said : #3

thank for the support. it is great to have this kind of support especially as i live in a village in India. to get connected i need to drive to the nearest town 25 KM away. hence the late response.

to answer warrens question i was able to get the usb disk working but not the rest of the partitiond disk to be seen.

in the new reinstallation i resized the ntfc and installed ubuntu in its own partition.

 i reformatted the system with windows again and set a partition for windows and a 430gb for documents. i downloaded linux 12.10 and reinstalled the linux again.

i installed the gparted partition editor and made the 430 gb again with in in a ntfs format.

the current partition are :
partition file system mount point label size used unused
/dev/sda1 ntfs system reserved 100.00 mib 33.59 66.4 mib
/devsda2 ntfs 49.65 24.41 25.24
/dec/sda3 extended 15.62 - -
      /dev/sda5 ext4 11.72 3.2 gib 8.60gib
    /dev/sda6 linux-swap 3. 90 - -
  /dev/sda4 /media/rajen/051E-FEA9 400.39 200.13 400.20 GIB BOOT
unallocated unallocated 1.02mib - --------

i now can see 430 gb one drive and have 53 gb as the ubuntu disk . I am not sure where the rest of the gb are of the 500gb hdd. anyway it all seems to work except for the mobile broadband usb data card which is from a company called "MTS". it does show up in the list but i dont know how to go further from there as it does not appear on the desktop.

Warren Hill (warren-hill) said : #4

From the information above you have have two ntfs (windows) partitions
sda1 and sda2.

If you want to have access to these check if they are mounted open a terminal by pressing CTRL+ALT+T and enter the command

------------------------------------------------------------------
sudo fdisk -l; mount | grep ^/dev
------------------------------------------------------------------
Enter password when requested. There is no feedback but the password is being accepted just type it and press enter.

This will tell you if the drives are mounted and where. If they are not mounted take a look here

https://help.ubuntu.com/community/Mount/USB

If you need further help post the results here otherwise please mark the question solved.

---
Broadband is a separate issue I won't answer it in this question as we want to keep to one question per problem so its easier for other people to use this forum.

Open a separate question stating

1. What the problem is - i.e. That you can't get your USB broadband dongle to work

2. The model and manufacturer of your dongle and who your network provider is

3. The output of the following command

-------------------------------------------------------------------------------
lsb_release -a; uname -a; lsusb; lshw -C network; ifconfig
-------------------------------------------------------------------------------

We will be happy to try and help

Rajen Varada (rajen-varada) said : #5

thanks a ton, if you ever travel to India, i owe you a trek in the jungle to watch wild elephants.