SSD drive not recognize

Asked by or yahud on 2013-01-01

Hello, I use kubuntu 12.10 and I have a samsung 830 256gb SSD..... kubuntu recognize the SSD as IDE and it work very slow compare to windows that recognize it as SSD.

what should I do to make kubuntu recognize it as SSD?

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-02
Last reply:
2013-01-02

Do you have the BIOS configured to use the SATA in PATA mode (all drives are IDE unless you go back to 1980)

or yahud (oryahud) said : #2

I dont think so because my windows recognize the ssd...
How can I check it?

Thanks!

N1ck 7h0m4d4k15 (nicktux) said : #3

How you checked that Kubuntu recognized the SSD as IDE ? The slowness of the system can be related to many things also.

Lets see some results

sudo lshw -businfo | grep -e storage -e volume

sudo parted -l

sudo fdisk -l

Thanks

or yahud (oryahud) said : #4

my results are....

sudo lshw -businfo | grep -e storage -e volume:

pci@0000:00:1f.1 storage 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller
pci@0000:00:1f.2 storage 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode]
                  scsi0 storage
scsi@0:0.0.0,1 /dev/sda1 volume 100MiB Windows NTFS volume
scsi@0:0.0.0,2 /dev/sda2 volume 238GiB Windows NTFS volume
                  scsi3 storage

sudo parted -l:

Model: ATA SAMSUNG SSD 830 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 106MB 105MB primary ntfs boot
 2 106MB 256GB 256GB primary ntfs

sudo fdisk -l:

Disk /dev/sda: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6b4b366e

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 500115455 249954304 7 HPFS/NTFS/exFAT

Thanks!!!

N1ck 7h0m4d4k15 (nicktux) said : #5

First of all , this is not a regular installation of Ubuntu. Wubi.exe is almost a virtual installation.

The SATA Controller [ACHI mode] probably is your SSD. To enable trim on SSD ACHI mode should be enabled , some motherboards have this by default.

As for the IDE controller.. I'm not sure , but look if your MB has one.

And the slow system , I guess that this is due to wubi.exe installation. Yes , wubi is slower than a regular install because of the virtual hard drive. Ubuntu is not running on native filesystem (ext4) but on a virtual HDD inside Windows.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask or yahud for more information if necessary.

To post a message you must log in.