Trying to recover a server's hard disk: cannot mount the drive on another machine

Asked by Bernard Munger on 2012-12-24

I've experienced a major problem with my Zimbra Server on Ubuntu 10.04.4.

The system goes up, gives all sorts of error messages that seem related to hard disk failures. So, I booted with a Live CD and attempted to ddrescue the drive. Then I got all sort of other error messages and I'm starting to suspect the computer also to have trouble.

But now I'm trying to mount the faulty (?) boot drive on another just-installed Ubuntu on another computer... but it tells me it cannot mount the LVM partition...

"mount: unknown filesystem type 'LVM2_member'"

What's that error message?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Bernard Munger
Solved:
2012-12-24
Last query:
2012-12-24
Last reply:
2012-12-24
Thomas Kr├╝ger (thkrueger) said : #1

Maybe this link gives you an idea: http://www.brandonhutchinson.com/Mounting_a_Linux_LVM_volume.html

If it does not: how did you try to mount the volume?

Bernard Munger (bmunger-s) said : #2

I've tried running the pvs program but it's not installed and it seems not to be in the list of apt-get...

Bernard Munger (bmunger-s) said : #3

Thanks for the quick response, though!

Bernard Munger (bmunger-s) said : #4

Found in another site that I need to install lvm2 with:
apt-get install lvm2

Installing now...

Bernard Munger (bmunger-s) said : #5

I could not get the partition mounted...

I decided to reboot using the rescue environment which was able to mount it...

Weird.

But problem solved (until I need to do that again NOT within the rescue environment).

So now I'm copying all I can salvage from that disk...

Bernard Munger (bmunger-s) said : #6

I've finally found a good method to use LVM partition from Linux.

First, make sure the lvm2 package is installed:
$ sudo apt-get install lvm2

Second, you can scan to get the partitions names:
$ sudo vgscan

Third, load the virtual group of partitions:
$ sudo vgchange -ay

Now that you have the names and you've loaded the group, you have the mount command possible. The mount command will vary depending on the name of the virtual group and the partition name. It will look like:
$ sudo mount /dev/VolGroup00/LogVol00
where you replace VolGroup00 and LogVol00 witht eh group's name and the logical volume's partition name.

Mine was:
$ sudo mount /dev/zimbra/root

The you can fsck the file system with a check for bad blocks using the following:

fsck -y -cc -n /dev/zimbra/root

It takes forever to run on a 500Gb partition but it gets rid of bad blocks.

My computer still has trouble so I'm not sure if the problem was only that of the hard disk... but I've ordered two 1Tb hard disk to set up a RAID to avoid further problems.... 131$ all included and delivered to my door in a few days... Man that's a deal!

I ordered from Memory Express and I'm waiting for them to arrive to install a new system... I salvaged my Zimbra installation and I'm running on my (slow) backup system...