cannot access windows files and folders

Asked by renaldo on 2012-12-10

i just installed ubuntu 12.10 os onto my window 7 hp laptop.
It is a dual os system now with both windows 7 and ubuntu 12.10 os available on boot to choose which to load. im currenntly typing this message using the windows 7 os.
My problem/ question is how do i access files from my windows 7 part of the laptop while im running the ubuntu os? (same machine, i want to acess my pic, movies and music and stuff like that)

tried reading ubuntu help manual, but nothing is there in regards to this.
Searched online and at the ubuntu community help forum, no one has this problem the only similar prob they have is by using to pcs to try to connect there files by which wont work for me because im not on a network.

ive heard about samba but when i went onto the website for it and read what it actually does that doesnt sound like what i need. (its descriptions lead me to believe its for molre than one machine, pehaps a desktop and a laptop)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-12-10
Last query:
2012-12-10
Last reply:
2012-12-10

Did you install using Wubi (installed in Windows) or did you resize your NTFS and install to the freed space?

Can you give the output of:

sudo fdisk -l; lsb_release -a; uname -a; mount

Thanks

renaldo (lewiz2011) said : #2

I installed via windows installer

On Dec 10, 2012 10:26 AM, "actionparsnip" <
<email address hidden>> wrote:
>
> Your question #216406 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/216406
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Did you install using Wubi (installed in Windows) or did you resize your
> NTFS and install to the freed space?
>
> Can you give the output of:
>
> sudo fdisk -l; lsb_release -a; uname -a; mount
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/216406
>
> You received this question notification because you asked the question.

renaldo (lewiz2011) said : #3

tried running that command in windows command line and the result is it isnt recognized as an internal or external command

If you run:

file /host

Does it state it is a folder?

renaldo (lewiz2011) said : #5

ran it with the run tool in windows nothing happened am i suppose to dpo it running the ubuntu os?

Run it in a terminal. You can run a terminal by pressing CTRL+ALT+T

renaldo (lewiz2011) said : #7

tried that same thing, is there a specific file you want me to look for? cause i can do that through the c drive.
These command line commands aren't returning any results just the generic windows does not recognize this an an external or internal command

There is no 'C drive' in Linux, its a Windows construt.

Can you run:

sudo fdisk -l; lsb_release -a; uname -a; mount; file /host

in the terminal, copy ALL the output and paste the text here as an update

Thanks

samuel (samuel-h) said : #9

actionparsnip means for you to run the commands in the ubuntu OS ;)

renaldo (lewiz2011) said : #10

just rebooted into ub unto and ran the command and here is the output

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3a3f7009

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 409599 203776 7 HPFS/NTFS/exFAT
/dev/sda2 409600 586268671 292929536 7 HPFS/NTFS/exFAT
/dev/sda3 586268672 624928767 19330048 7 HPFS/NTFS/exFAT
/dev/sda4 624928768 625140399 105816 c W95 FAT32 (LBA)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux bossman 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
/dev/loop0 on / type ext3 (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda2 on /host type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
gvfsd-fuse on /run/user/bossman/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=bossman)
/host: directory

Perfect, you can now easily access your data once you run:

ln -s /host ~/Windows\ Files

In the terminal. Now, when you open your home folder you will see a new folder.

This is the ONLY advantage of Wubi in my opinion. I suggest you move away from it and use a real install once you have judged the OS.

renaldo (lewiz2011) said : #12

Thanks actionparsnip, that solved my question.

renaldo (lewiz2011) said : #13

thansk alot!