Can't sync ipod nano g3 with Banshee nor Rhythmbox

Asked by Fred Kelsey on 2012-12-05

I'm running Ubuntu 10.04.3 on an old desktop, and I can't sync my iPod Nano G3 with Banshee nor Rhythmbox. It goes through the motions, but nothing gets synced.

I have to use Windows XP and Windows 7 iTunes to sync it. (other laptops)

I tried the following (I found on internet) but it's too technical for me to understand - so I don't know if this is the solution.

"How to downgrade iPod Nano 3rd Generation from 1.1.3 to 1.03...

To get back to 1.0.3, first go to your User Library > iTunes > iPod and remove the two files labeled as "iPod_26.1.1". I also removed any "previous iTunes Libraries" from my User Documents > Music folder. Then turn off your internet connection to prevent an automatic update to version 1.1. After opening iTunes and connecting the iPod, you can then "Restore", and it will ask if you want the previous version that you have in your library. After restore and sync, you're back in business!!" (end of quote)

Any help is appreciated...

Thank you,
Fred

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Fred Kelsey
Solved:
2012-12-07
Last query:
2012-12-07
Last reply:
2012-12-05

When you want to unplug the device, do you use the 'safely remove' feature in your OS or do you just yank it out?

Hi Action Parsnip..
Of course I Safely remove the iPod.. The iPod seems to sync, but when I try
to play music on it, there is no music there - even 'tho the iPod space is
used up. (This iPod Nano only holds 4GB)

It syncs fine with iTunes.. so I know the iPod works fine. Maybe Apple
doesn't like Ubuntu/Linux??

Thanks for your interest in trying to help.
Fred

On Wed, Dec 5, 2012 at 1:35 AM, actionparsnip <
<email address hidden>> wrote:

> Your question #215989 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/215989
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> When you want to unplug the device, do you use the 'safely remove'
> feature in your OS or do you just yank it out?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/215989
>
> You received this question notification because you asked the question.
>

Hi,

I guess I'm not the only one with this problem (according to various FAQ's) - so I'll just have to use iTunes on Windows for syncing my iPod.

Thanks for trying,
Fred

PS: I love Ubuntu for everything else..

Hi Fred,

I recently acquired an iPod nano 6th generation and this procedure worked for me in Ubuntu 13.10:

1) perform a restore of the ipod nano to factory settings in itunes in Windows
2) set up ipod for first time use in itunes in Windows
3) install spotify-client in Ubuntu 13.10 using these 4 commands:

sudo DEBIAN_FRONTEND=noninteractive apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59
sudo sh -c 'echo "deb http://repository.spotify.com stable non-free" >> /etc/apt/sources.list.d/spotify.list'
sudo DEBIAN_FRONTEND=noninteractive apt-get update
sudo DEBIAN_FRONTEND=noninteractive apt-get --yes --force-yes install spotify-client

4) then run spotify and it should just work fine... You should be able to sync files between Ubuntu and the ipod nano.

Hope this helps,

Mark