fsck checking when booting the system

Asked by jayasankar on 2012-11-30

sir,
I am using Ubuntu from 2010. when i installed ubuntu 11.10 in my dell inspiron N4050 laptop it was working fine. suddenly one day
while booting that shows that
fsck from util-linux 2.20.1
/dev/sda9: clean, 501325/1310720 files, 2958455/5242880 blocks
skipping profile in /etc/apparnor.d/disable: user.bin.firefox
skipping profile in /etc/apparnor.d/disable: user.sbin.rsystemlogd
  *Starting AppArwor profiles
fsck from util-linux 2.20.1
skipping profile in /etc/apparnor.d/disable: user.bin.firefox
skipping profile in /etc/apparnor.d/disable: user.sbin.rsystemlogd
  *Starting AppArwor profiles
fsck from util-linux 2.20.1
/dev/sda9: clean, 501325/1310720 files, 2958455/5242880 blocks
skipping profile in /etc/apparnor.d/disable: user.bin.firefox
skipping profile in /etc/apparnor.d/disable: user.sbin.rsystemlogd
  *Starting AppArwor profiles
fsck from util-linux 2.20.1
skipping profile in /etc/apparnor.d/disable: user.bin.firefox
skipping profile in /etc/apparnor.d/disable: user.sbin.rsystemlogd
  *Starting AppArwor profiles
...................................etc
this is repeating for 20 mnt then i can login..
after restarting again it will come.. like that.. and i uninstalled ubuntu and installed 12.04ls
Again i met with the similar problem.
i found one solution from ubuntu community..

"You're going to have to let it complete at least once. fsck is a legitimate health-check, and it's the "Right Thing" to do.

that said, if you ARE letting it complete, and it's still running every time you reboot, check the SMART results in the Disk Utility application (disk could be going bad), or adjust the frequency of disk checks with a command like:

#sudo tune2fs -c 50 /dev/sda1

be sure to change the device to your actual device name, and feel free to adjust the count as well."

i have done this. after ! week again it came.. i am totally disturbed because of this problem. I am expecting a permanent solution for this. otherwise i have to move to fedora. because my work is depends on linux os. but i still want to continue in ubuntu.. because am a fan of ubuntu. i liked that very much
Pleas give me a solution.
yours sincerely
jayasankar

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-30
Last reply:
2012-11-30
Joakim Langvand (jlangvand) said : #1

So, did you check you SMART-status? You can check it like this:
Disk Utility (or Disks in 12.10) -> Select your hard drive

In pre-12.10, you will see an indicator for SMART status. You will also have the option to se detailed output. If you find something not normal, post it here.

In 12.10, you'll have to press the small cogwheels in the top right part of the Disks app, and select SMART Data and tests.

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi ,
you can increase the number from 50 to 100 . You said "after a week" , so I assume in a week you had 50 reboots of your PC.

Well , I don't know why fsck stuck , but you can check your drive manually from a Live CD - USB of Ubuntu. After load and click "Try Ubuntu" , open a terminal (CTR+ALT+T) and give this command

sudo fsck -y /dev/sdX

where X , replace it with the number of partition Ubuntu is installed.

If you want to increase the number of reboots , you can do (from the installed OS , NOT LiveCD-USB)

sudo tune2fs -c 100 /dev/sdaX

again , where X place the number of partition with Ubuntu.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask jayasankar for more information if necessary.

To post a message you must log in.