USB Hotplug not working

Asked by Manfred Meyer on 2012-11-24

Hi,
I installed Ubuntu 12.10 on my new Notebook (Asus Zenbook Prime UX31a) and the USB hotplug is not working (USB3.0 ports are used).

When I restart the notebook with the USB devices plugged in, all devices are found by Ubuntu.

I tried some flash devices and a Logitech MX510, with the same behaviour everywhere.

I tried to find some messages in the syslog, but I couldn't find any notification there.

Imho, there is also no relevant option in the EFI setup.

I hope you can help me, thanks a lot!

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-12
Last reply:
2012-12-19

What USB devices have you tested?

Manfred Meyer (manni-m) said : #2

I tried a Logitech MX510 mice,
two USB flash devices (Data traveler and Verbatim, both with USB 2.0
and my smartphone (Sony Xperia Neo)

Thomas Kr├╝ger (thkrueger) said : #3

AFAIR there was a known problem with this notebook and the btusb module. You should try to blacklist it and see it it works better.

Manfred Meyer (manni-m) said : #4

Thank you for the hint

Unfortunately, it does not solve my problem. I blacklisted 'btusb' and checked it with 'lsmod' after reboot, if the module really isn't loaded.

Hotplug is still not working.

Do you have the latest BIOS?

Manfred Meyer (manni-m) said : #6

Yes, had preinstalled BIOS version 214 and recently updated to the new version 216. With both versions, hotplug is not working.

N1ck 7h0m4d4k15 (nicktux) said : #7

Hi ,

open a terminal and give this command

~$ sudo dmesg --clear

Then plug in a USB device (flash drive , or mouse .. etc) and give the results of

~$ dmesg

If the results are zero (nothing) then try something else ..

Open a terminal and write this command

~$ sudo udevadm monitor -e

then plug in something , and see if any results appeared.

Thanks

I suggest you report a bug too

Manfred Meyer (manni-m) said : #9

Hi,
neither dmesg, nor udevadm gives me any results....

The only message I get is, when I start udevadm...

$ sudo udevadm monitor -e
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

If you grab the Raring ISO (Ubuntu 13.04) and put it on a CD or USB stick, is it ok there?

Manfred Meyer (manni-m) said : #11

Okay, I just tried it with the USB stick, I've installed my system from, it's with 12.10.

When I boot from the stick, it works fine.

What I forgot to tell, that I'm using the proposed release. I don't know if it's relevant, because I not even get an error message, so it's maybe just a misconfiguration?

Did you upgrade from Precise to Quantal, or did you clean install Quantal?

Manfred Meyer (manni-m) said : #13

Clean install

I suggest you report a bug and add that the live OS works ok but the installed OS does not.

Manfred Meyer (manni-m) said : #16

Ok, one more thing I found out:

I just installed darktable for organizing my photos. It has a support for usb devices.

When I start darktable with a usb device plugged in, the device is detected immedately. And it doesn't matter, if its a by darktable supported device or not, even my Logitech MX510 is detected.

When darktable is closed, the usb devices are no longer detected.

So my guess: Is there maybe a missing kernel module?

Janez Urevc (janez-0) said : #17

I have exactly the same problem. Did you manage to find any usable solution?

Janez Urevc (janez-0) said : #18

Similar as Manfred experienced with darktable I did with shotwell:

1. If I boot with my usb flash plugged in during boot everything works fine
2. If I plug USB flash in when I have already booted the system it is not detected at all (nothing happens in lsusb, dmesg, ...)
3. If I run shotwell after that system recognizes and mount USB flash

Where should we report this bug?

Manfred Meyer (manni-m) said : #19

I don't know...

When I've connected my android smartphone, hotplug is working for every device, but only, if the smartphone is connected.

Janez Stupar (janez-stupar) said : #20

I have exactly the same issue, on ASUS UX32VD.

I have BIOS 2.13 (latest at the time) and Kernel 3.7.0

Janez Urevc (janez-0) said : #21

Do we know if this appears only on 3.7 or 3.5 also?

Janez Urevc (janez-0) said : #22

Changing status....

Boris (boria83) said : #23

The same situation: I have the same machine Asus UX31a, and all described below exactly the same. The usb hotplug works if I plugged the usb device then the system is boot, or (as revealed in this forum), if I run Shotwell.

Manfred Meyer (manni-m) said : #24

Ok, I also still have the problems...

Can you help with this problem?

Provide an answer of your own, or ask Manfred Meyer for more information if necessary.

To post a message you must log in.