New 12.04 LTS install encfs home folder does not stay mounted

Asked by Maurice Woodworth on 2012-11-21

I installed 12.04 on an Inspiron 1525 yesterday, and migrated data from an old windows Vista install.

Other than having to add a line to /etc/modules to get the wireless working.
It seemed at first to be a trouble free install and migration.

I have one last, BIG problem. When installing I chose to have the home folder encrypted.

Everything works fine for a few minutes after boot, but after a few minutes the home folder for the user I am logged in as gets unmounted.

I want it to stay mounted. Even if I remount from the command line it will unmount again eventually.

It causes problems for apps using files in the users home.

Firefox and thunderbird do not like it when the home folder gets unmounted when they're running.

I have a hunch as to what is happening.

I understand that encfs has a -i option for unmounting after x minutes of inactivity.

I don't know which file(s) contain the information for triggering encfs mounts at boot time.

I suspect I may just need to get rid of the timeout option.

Could be something else though.

Has anyone else seen this problem and found a solution for it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Maurice Woodworth
Solved:
2012-11-23
Last query:
2012-11-23
Last reply:
Maurice Woodworth (mwoodwor) said : #1

I've done some reading up on other encfs home folder problems, and I wonder if renaming or removing ~/.ecryptfs/auto-umount may be a way to prevent this from happening.

Maurice Woodworth (mwoodwor) said : #2

I'm not sure if I've solved the problem so much as put a band-aid on it. I ended up renaming the auto-umount file. That seems to have stopped the unmounts. It looks like /etc/mtab is where the line is that mounts the ecryptfs folders. I was wrong in initially thinking it was an encfs folder. Then I found the home folder wasn't mounting every time the system was booted so I added a line to rc.local to su to the ID and run the command ecryptfs-mount-private. So far those two actions seem to have made the desktop usable.

Greg Ruo (la1234uk) said : #3

I have exactly the same problem on a Ubuntu 12.04 32bit, on a home made Asus platform (intel duo CPU E8500x2) .
My home folder does not stay mounted, I mount with ecryptfs-mount-private and after few minutes it just goes off again.
My system was stable for half a year, this problem appeared recently. Do not know exactly what is the reason.

Maurice, can you please give me a hand telling me step-by-step what you did exactly to put a band-aid on it? I tried to reproduce your solution, but I can figure it out because I am rather new to linux.

Greg

Greg Ruo (la1234uk) said : #4

previous message error: "[...] I can't figure it out [...]" not "[...] I can figure it out [...]"

Greg Ruo (la1234uk) said : #5

I solved the problem as maurice suggested. Just renamed ~/.ecryptfs/auto-umount to ~/.ecryptfs/auto-umount_original. Now home folder stays mounted. I didn't need to do any other steps.

The problems seems solved for me, but I did not understand what was the reason for the automatic unmounts.

Greg Ruo