How to read a floppy using Ubuntu 12.04

Asked by Rodney on 2012-10-28

I just upgraded from 10.04 to 12.04 on an older desk top computer. It has both a floppy and a Zip drive. I can use the Zip drive fine but can not read or write to the floppy. When I use the search function and type in “Disk Utility” I get the information on main drive, the Zip but nothing on the floppy except it is noted as being present. How do I read and write to it, at least read it as I have a lot of archive stuff on floppys I'd like to be able to read? I can read and write to the Zip drive fine.
 Here is the results of the fstab file if that will help.
rodney3@rodney3-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda1 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=7049e8b1-5f40-499a-a200-c8d3e64b929d none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Question information

English Edit question
Ubuntu util-linux Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

If you put a floppy in and run:

sudo mount /media/floppy0

does it mount?

Remember that when you want to eject the foppy, you must unmount it so that the final sync can happen and you won't damage the device.

Rodney (rciwan) said : #2

The light on the floppy does light and the floppy now shows up in "Disk Utility" when I click on "floppy drive" but the status shows "no media detected" when there is known data on the floppy.

Rodney (rciwan) said : #3

The above comment was made after running sudo mount/media/floppyo and then going to "disk utility".

No media detected means there is no disk detected in the drive. It's not about the lack of data on the floppy disk.

Rodney (rciwan) said : #5

I may have found a solution. If I go to the terminal and type in
udisks --mount /def/fd0
the disk mounts. If I then go back to the unity screen and bring up Libreoffice I can open the text files in Writer.
Thanks for the help you folks have given me. Rodney