upgrade 12.10, cannot read USB device

Asked by Denis White on 2012-10-25

After upgrade to 12.10, I cannot read USB memory devices. Message is,

Unable to mount UDISK 20X
Adding read ACL for uid 1000 to '/media/denis' failed: Operation not supported

System:
Ubuntu 12.10 (quantal)
Gnome 3.6.0 (Ubuntu 2012-10-04)
Kernel 3.5.0-17-generic (#28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012)
Xorg 1.13.0 (08 October 2012 03:34:08PM)
CPU Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz L2 cache 3072 KB
CPU Flags fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm
Memory total 4036 MiB

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Subin Hutton
Solved:
2012-10-26
Last query:
2012-10-26
Last reply:
2012-10-26

This question was reopened

Best Subin Hutton (djlynux) said : #1

Follow the steps below and try if it fixes your issue.

Open the terminal and type the commands

sudo mkdir /media/$USER
sudo chown $USER.$USER /media/$USER

What file system does the USB partition use?
When you last unplugged it, did you safely remove it in the OS before physically removing it?

Denis White (capeblanco) said : #3

Thanks

Denis White (capeblanco) said : #4

To actionparsnip: yes last device was safely removed.

Denis White (capeblanco) said : #5

To Subin Hutton: thanks, that solved problem.

Denis White (capeblanco) said : #6

Thanks Subin Hutton, that solved my question.

Dirk Haar (mideal.de) said : #7

It would be best if this could be set during setup, or wouldn't that be possible?
BTW: Thanks a lot!

Hello,
I had the same problem, and used this trick to fix it :
sudo mkdir /media/$USER
sudo chown $USER.$USER /media/$USER

it is not very convenient!
regards