an error occured while mounting ... on an SSD

Asked by Zorbeck Legras on 2012-10-25

I recently added a new SSD to my dual boot system running Win7 and Ubuntu 12.04 LTS
I duplicated the original dual boot drive (300 GB HD) into the new SSD (500 GB SSD) and everything worked fine with the new drive, including grub. Surprisingly, Windows7, originally installed on the HD, did not complain and works much faster.

Then I decided to use the unmounted part (circa 200 GB) of the new SSD for mounting a subdir of my home: /home/zorbeck/Pictures
I created the unformated partition through GParted (which gave it the type of ext2)

The problem I have is that since then, when booting, the Ubuntu startup sequence stops with the following error message:
"An error occured while mounting /home/zorbeck/Pictures
Press S to skip or M for manual recovery"

Pressing M gives me access to a terminal and when I type the following command it succeeds:
mount -t ext2 /dev/sda3 /home/zorbeck/Pictures

Rights as follows (`ls -l `):
drwxr-xr-x 4 zorbeck zorbeck 4096 Oct 24 21:39 Pictures

I wonder what is wrong with my setup.

fstab as follows:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sdb5 during installation
UUID=e0a70d23-1172-4883-9a66-21fd331cb8e0 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb6 during installation
UUID=b573f6a8-70c1-4a08-9669-3f3aa578ac92 none swap sw 0 0
UUID=2f84f091-2e89-4037-a798-cd48075e8fe8 /home/zorbeck/Pictures ext2 discard,noatime,nodiratime,user 0 2

sudo blkid gives following output:
/dev/sda1: LABEL="System Reserved" UUID="462C64A32C648FAB" TYPE="ntfs"
/dev/sda2: UUID="EC58686258682D90" TYPE="ntfs"
/dev/sda3: UUID="2f84f091-2e89-4037-a798-cd48075e8fe8" TYPE="ext2"
/dev/sdb1: LABEL="System Reserved" UUID="462C64A32C648FAB" TYPE="ntfs"
/dev/sdb2: UUID="EC58686258682D90" TYPE="ntfs"
/dev/sdc1: LABEL="SATA2_600" UUID="920A0CE10A0CC467" TYPE="ntfs"
/dev/sr0: LABEL="Disc" TYPE="iso9660"
/dev/sdd1: LABEL="SATA1G_1" UUID="AA3616FB3616C7E9" TYPE="ntfs"
/dev/sdd5: UUID="e0a70d23-1172-4883-9a66-21fd331cb8e0" TYPE="ext4"
/dev/sdd6: UUID="b573f6a8-70c1-4a08-9669-3f3aa578ac92" TYPE="swap"
/dev/sde1: LABEL="SATA3_500" UUID="42983B66983B579D" TYPE="ntfs"
/dev/sdf1: LABEL="MAXELL HDD" UUID="1700-063B" TYPE="vfat"

As you can see the partition I want to mount is on /dev/sda3 but I cannot figure out what is wrong
I suspect an issue with fstab parameters but I cannot find out.
Also worth to note: at first sight, I did not find the error message in the logs (but there are so many logs I may not look inot the correct one).
Any helpf would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-27
Last query:
2012-10-27
Last reply:
2012-10-25

Have you fsck'd the partition?

Zorbeck Legras (zorbeck) said : #2

Yes, no issue :
sudo umount /dev/sda3
[sudo] password for zorbeck:
zorbeck@zorbeck-PC:~$ sudo fsck -rV /dev/sda3
fsck from util-linux 2.20.1
[/sbin/fsck.ext2 (1) -- /home/zorbeck/Pictures] fsck.ext2 -r /dev/sda3
e2fsck 1.42 (29-Nov-2011)
/dev/sda3: clean, 70/12943360 files, 850022/51768064 blocks
and of course doing the manual mount afterwards is successful: sudo mount -t ext2 /dev/sda3 /home/zorbeck/Pictures

I suspect that the issue is related to some permission/rights issue but I cannot figure out where in the startup process..
I already tried several combinations around "discard,noatime,nodiratime,user", e.g. "discard,noatime,nodiratime,user" in the fstab but it does not change the result.

Maybe it would help if I knew in which log file to look for more details...

You could unmount then remount the file system using /etc/rc.local

Add commands above the 'exit 0' line

Zorbeck Legras (zorbeck) said : #4

Thanks actionparsnip, that solved my question.