Why did ubuntu change the default mount point of external devices from /media to /media/home

Asked by Nithin C on 2012-10-09

This is a big problem as all the paths in my system has changed as mount point is changed. All the settings has become obsolate with this one change and now all programs need to be reconfigured. Please tell me how can change the default mount point back to /media instead of /media/usernme? Or is the best solution is to switch back to 12.04?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-02
Last reply:
2012-11-02

What is the output of:

lsb_release -a; uname -a

Thanks

Nithin C (nithin-aneesh) said : #2

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

uname -a
Linux SECTUMSEMPRA 3.5.0-17-generic #27-Ubuntu SMP Fri Oct 5 01:36:06 UTC 2012 i686 i686 i686 GNU/Linux

Plug in a USB stick and mount it, then run

mount

What is the output?

Nithin C (nithin-aneesh) said : #4

mount
/dev/sda6 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda7 on /home type ext4 (rw)
gvfsd-fuse on /run/user/nithin/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=nithin)
/dev/sdb5 on /media/nithin/SALVIO HEXIA type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdb1 on /media/nithin/EXPECTO PATRONUM type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdb6 on /media/nithin/LACARNUM INFLAMA type ext4 (rw,nosuid,nodev,uhelper=udisks2)

Nithin C (nithin-aneesh) said : #5

Also the safely remove option is not available in the right click menu for any device.

TroubleMakerDV (grayman2000) said : #6

The fastest workaround I found is to create symlinks under /media pointing to new mount points

For example:

was: /media/progs-1t
became: /media/sergei/progs-1t

after adding

ln -s /media/sergei/progs-1t /media/progs-1t

no programs used that volume do require re-configuration.

But the change remains irritating, anyway.

Nithin C (nithin-aneesh) said : #8

Thanks TroubleMakerDV, that solved my question.

Nithin C (nithin-aneesh) said : #9

Ok. That solves the problem. That is not a permenant fix and the change remains irritating.

TroubleMakerDV (grayman2000) said : #10

Just hope that this workaround will save someone's nerves and patience :-)

(with sad smile): it is an another demonstration of flexibility of "*nix-way" - the possibility to symlink anything...

BTW, why did you complained about absence of "safe removal" item in context menu? Under XUbuntu 12.10 (XFCE 4.10) I still have this option and can disconnect external devices with ease.

Nithin C (nithin-aneesh) said : #11

The safely remove option is mission from Ubuntu 12.10. I have the option to unmount.

Thank you TroubleMakerDV,

That symbolic link recovered a whole directory tree of symbolically linked files that would have been painful to fix otherwise.

Can you help with this problem?

Provide an answer of your own, or ask Nithin C for more information if necessary.

To post a message you must log in.