Trying to access files from Windows installation from Ubuntu

Asked by RickRogers on 2012-10-08

I have a laptop with a Windows Vista intallation that won't load up (syatem error) so I run Ubuntu from USB, and works great. I viewed the files that were in folders that were created in Windows and put in USB to copy them onto. Then the (Windows) folders disappeared from view and I have been unable to find them again. I have searched but cannot find a \file system\ host folder (as advised under another thread as being the location for the files). advice appreciated. Rick

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
RickRogers
Solved:
2012-10-09
Last query:
2012-10-09
Last reply:
2012-10-09

Mount the partition using nautilus, or you can use command line.

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi ,

open a terminal [Ctrl]+[Alt]+[t] keys combo and give this command

sudo fdisk -l

you will see windows vista there listed . You will understand it from the file system HPFS/NTFS/exFAT

If we assume now , that this partition is /dev/sda2 , then you must do

sudo mount /dev/sda2 /mnt

cd /mnt && ls

and you will see your files. Then you can connect to any folder you want with cd command , eg : cd users/yourname/
and with rsync command you can backup your files

rsync -aS "target directory" "destination directory" . This is the terminal way , effective and fast. If you want further help , step-by-step , we will need more info.

Another way is from nautilus file manager .
Give in terminal this command

nautilus

and find your windows partition listed left Under Devices. Click one time to mount the partition and then just copy-paste the files you want. (this is the graphical way)

Thanks

RickRogers (rickrogers) said : #3

Thanks for the advice. I tried the terminal method, but it couldn't find the users/ folder. (may be finger problems...).

I couldn't navigate using Nautilus, but I managed to find them in the end - Nautilus did not show anything under Devices. However, when I next went to save a file the location of the Windows folder was shown in options - I right clicked and did an 'add bookmark' and, hey presto! the bookmark appeared in Nautilus -problem solved. Thanks again.